summaryrefslogtreecommitdiffstats
path: root/target/linux/imx6
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-11-24 19:12:19 +0000
committerJohn Crispin <john@openwrt.org>2014-11-24 19:12:19 +0000
commit5f51cfcf55e2c8de3d75daeefe8be5b75eb839ae (patch)
tree9a25c410f006c749e57e0597a59e5c5ac98ea223 /target/linux/imx6
parent623f3bda54ec0e3ad202ad8a3b2e94d69909d4f6 (diff)
downloadmaster-31e0f0ae-5f51cfcf55e2c8de3d75daeefe8be5b75eb839ae.tar.gz
master-31e0f0ae-5f51cfcf55e2c8de3d75daeefe8be5b75eb839ae.tar.bz2
master-31e0f0ae-5f51cfcf55e2c8de3d75daeefe8be5b75eb839ae.zip
imx6: make the default config bootable on ventana
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 43369
Diffstat (limited to 'target/linux/imx6')
-rw-r--r--target/linux/imx6/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 391db78474..3381473c7f 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -44,9 +44,9 @@ endef
define Image/InstallKernel/Template
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL)$(CONFIG_TARGET_imx6_VENTANA),)
$(INSTALL_DIR) $(TARGET_DIR)/boot
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE)$(CONFIG_TARGET_imx6_VENTANA),)
$(CP) $(BIN_DIR)/$(IMG_PREFIX)-uImage $(TARGET_DIR)/boot/
ln -sf $(IMG_PREFIX)-uImage $(TARGET_DIR)/boot/uImage
endif
@@ -61,7 +61,7 @@ define Image/InstallKernel/Template
endif
endif
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB)$(CONFIG_TARGET_imx6_VENTANA),)
$(INSTALL_DIR) $(TARGET_DIR)/boot
$(foreach dts,$(shell echo $(1)), \
$(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(dts).dtb $(TARGET_DIR)/boot/ ; \