summaryrefslogtreecommitdiffstats
path: root/target/linux/imx6
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-08-08 13:38:25 +0000
committerLuka Perkov <luka@openwrt.org>2014-08-08 13:38:25 +0000
commit2b6d364a2d210f4eeb8bdbd91367f1068982bc98 (patch)
tree300c6f88bada2c2ae1bc9b8a55eb588132d8ad9c /target/linux/imx6
parentdd8d72909634e0ba521519748827cb06f8c3f37d (diff)
downloadmaster-31e0f0ae-2b6d364a2d210f4eeb8bdbd91367f1068982bc98.tar.gz
master-31e0f0ae-2b6d364a2d210f4eeb8bdbd91367f1068982bc98.tar.bz2
master-31e0f0ae-2b6d364a2d210f4eeb8bdbd91367f1068982bc98.zip
imx6: drop ventana kernel/rootfs hack
In r41578 this was added in order to make default images bootable for the BB release. We need more generic approach for this. Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 42071
Diffstat (limited to 'target/linux/imx6')
-rw-r--r--target/linux/imx6/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 54cdfd5186..2e2e11b6ac 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -42,9 +42,9 @@ endef
define Image/InstallKernel/Template
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL)$(CONFIG_TARGET_imx6_VENTANA),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL),)
$(INSTALL_DIR) $(TARGET_DIR)/boot
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE)$(CONFIG_TARGET_imx6_VENTANA),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE),)
$(CP) $(BIN_DIR)/$(IMG_PREFIX)-uImage $(TARGET_DIR)/boot/
ln -sf $(IMG_PREFIX)-uImage $(TARGET_DIR)/boot/uImage
endif
@@ -59,7 +59,7 @@ define Image/InstallKernel/Template
endif
endif
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB)$(CONFIG_TARGET_imx6_VENTANA),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
$(INSTALL_DIR) $(TARGET_DIR)/boot
$(foreach dts,$(shell echo $(1)), \
$(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(dts).dtb $(TARGET_DIR)/boot/ ; \