summaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/profiles
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-08-11 20:35:13 +0000
committerLuka Perkov <luka@openwrt.org>2014-08-11 20:35:13 +0000
commitfa8e8d262ead0f30cdb82e84965ca4884ffe1c10 (patch)
tree6cb097a952a135b219d780a1409b9786b18d689b /target/linux/imx6/profiles
parentdcacd65281c7c11b82aa095395033a290e89d25e (diff)
downloadmaster-31e0f0ae-fa8e8d262ead0f30cdb82e84965ca4884ffe1c10.tar.gz
master-31e0f0ae-fa8e8d262ead0f30cdb82e84965ca4884ffe1c10.tar.bz2
master-31e0f0ae-fa8e8d262ead0f30cdb82e84965ca4884ffe1c10.zip
imx6: kernel: add GW5520 support
The GW5520 is a small form-factor single-board computer with the following features: * 70x100mm form-factor * IMX6DL 800MHz SoC (IMX6Q optional) * 512MB 32bit DDR3 SDRAM (up to 2GB optional) * 256MB NAND FLASH (up to 2GB optional) * Gateworks System Controller * 2x front-panel Intel i210 GbE adapters with passive PoE support * 2x MiniPCIe sockets with USB support * 2x front-panel USB * 1x rear-panel full-size HDMI connector * 1x front-panel bi-color user LED * 1x front-panel user pushbutton * 1x rear-panel barrel jack for power * 1x Application connector with: * 2x TTL level UARTs * 10x TTL level Digital IO Signed-off-by: Tim Harvey <tharvey@gateworks.com> SVN-Revision: 42148
Diffstat (limited to 'target/linux/imx6/profiles')
-rw-r--r--target/linux/imx6/profiles/120-gateworks.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/imx6/profiles/120-gateworks.mk b/target/linux/imx6/profiles/120-gateworks.mk
index 39c466353f..524e0c4573 100644
--- a/target/linux/imx6/profiles/120-gateworks.mk
+++ b/target/linux/imx6/profiles/120-gateworks.mk
@@ -41,10 +41,12 @@ VENTANA_DTS:= \
imx6dl-gw52xx \
imx6dl-gw53xx \
imx6dl-gw54xx \
+ imx6dl-gw552x \
imx6q-gw51xx \
imx6q-gw52xx \
imx6q-gw53xx \
imx6q-gw54xx \
- imx6q-gw5400-a
+ imx6q-gw5400-a \
+ imx6q-gw552x
$(eval $(call Profile,VENTANA))