summaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/profiles
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-11-18 22:23:42 +0000
committerLuka Perkov <luka@openwrt.org>2013-11-18 22:23:42 +0000
commitc108ddb20963360142dca2c639c133678adef281 (patch)
tree6939169e9625da129420497d65fe1a1e76aca112 /target/linux/imx6/profiles
parentf552d290c6908632d32ed0be133384e013b483bd (diff)
downloadmaster-31e0f0ae-c108ddb20963360142dca2c639c133678adef281.tar.gz
master-31e0f0ae-c108ddb20963360142dca2c639c133678adef281.tar.bz2
master-31e0f0ae-c108ddb20963360142dca2c639c133678adef281.zip
imx6: merge all gateworks boards into one profile
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 38858
Diffstat (limited to 'target/linux/imx6/profiles')
-rw-r--r--target/linux/imx6/profiles/120-gateworks.mk51
1 files changed, 17 insertions, 34 deletions
diff --git a/target/linux/imx6/profiles/120-gateworks.mk b/target/linux/imx6/profiles/120-gateworks.mk
index a62fd1e81a..16d59b43d6 100644
--- a/target/linux/imx6/profiles/120-gateworks.mk
+++ b/target/linux/imx6/profiles/120-gateworks.mk
@@ -5,53 +5,36 @@
# See /LICENSE for more information.
#
-define Profile/IMX6Q_GW5400_A
- NAME:=Gateworks Ventana GW5400-A
- PACKAGES:= \
- kmod-thermal-imx kmod-sky2 kmod-usb-chipidea kmod-usb-mxs-phy \
- kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000
-endef
-
-define Profile/IMX6Q_GW5400_A/Description
- The Gateworks GW5400-A family of products is based on the Freescale i.MX6Q SoC
- and offers a large variety of peripherals such as:
-
- * DDR3
- * SPI FLASH
- * 6x PCIe (3x with USB)
- * Optional expansion for additional USB/PCI based periperhals
- * 1x USB EHCI
- * 1x USB OTG
- * HDMI Audio/Video in/out
- * Analog Video in/out
- * Analog Audio in/out
- * Gateworks System Controller
-endef
-
-$(eval $(call Profile,IMX6Q_GW5400_A))
-
-define Profile/IMX6Q_GW54XX
- NAME:=Gateworks Ventana i.MX6 Quad GW54XX
+define Profile/VENTANA
+ NAME:=Gateworks Ventana family
PACKAGES:= \
kmod-thermal-imx kmod-sky2 kmod-usb-chipidea kmod-usb-mxs-phy \
kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
kobs-ng
endef
-define Profile/IMX6Q_GW54XX/Description
- The Gateworks GW54xx family of products is based on the Freescale i.MX6Q SoC
+define Profile/VENTANA/Description
+ The Gateworks Ventana family of products is based on the Freescale i.MX6Q SoC
and offers a large variety of peripherals such as:
* DDR3
- * NAND FLASH
- * 6x PCIe (3x with USB)
+ * NAND or SPI flash
+ * multiple PCIe (with USB for Cellular modems)
* Optional expansion for additional USB/PCI based periperhals
- * 1x USB EHCI
- * 1x USB OTG
+ * USB EHCI
+ * USB OTG
* HDMI Audio/Video in/out
* Analog Video in/out
* Analog Audio in/out
* Gateworks System Controller
+ * Optional GPS with PPS
+ * Canbus
+ * User GPIO
+ * mSATA
endef
-$(eval $(call Profile,IMX6Q_GW54XX))
+VENTANA_DTS:= \
+ imx6q-gw5400-a \
+ imx6q-gw54xx
+
+$(eval $(call Profile,VENTANA))