summaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/profiles
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-02 00:33:49 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-02 00:33:49 +0000
commit8f1499c4480068407810d42144a20e4b71ef6786 (patch)
tree16e72463d3d0588fad35dab88a4926c9cd8f90ea /target/linux/imx6/profiles
parent0eb732c659ff0f9a56e83817477aee947d3e5e36 (diff)
downloadmaster-31e0f0ae-8f1499c4480068407810d42144a20e4b71ef6786.tar.gz
master-31e0f0ae-8f1499c4480068407810d42144a20e4b71ef6786.tar.bz2
master-31e0f0ae-8f1499c4480068407810d42144a20e4b71ef6786.zip
imx6: add default profile
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 38282
Diffstat (limited to 'target/linux/imx6/profiles')
-rw-r--r--target/linux/imx6/profiles/100-Generic.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/imx6/profiles/100-Generic.mk b/target/linux/imx6/profiles/100-Generic.mk
new file mode 100644
index 0000000000..91ca3696ad
--- /dev/null
+++ b/target/linux/imx6/profiles/100-Generic.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic (default)
+ PACKAGES:= \
+ kmod-thermal-imx kmod-usb-chipidea kmod-usb-mxs-phy \
+ uboot-envtools
+endef
+
+define Profile/Generic/Description
+ Package set compatible with most Freescale i.MX 6 based boards.
+endef
+
+$(eval $(call Profile,Generic))