summaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/profiles
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2015-11-18 21:35:09 +0000
committerLuka Perkov <luka@openwrt.org>2015-11-18 21:35:09 +0000
commit8c6556049763053a40d55f4071d64111598f898c (patch)
tree9d3e8074250369fc43365d54048b7fed8caf60ec /target/linux/imx6/profiles
parent84c7a31535d9afc84a0f17960c5a3ef9c801485b (diff)
downloadmaster-31e0f0ae-8c6556049763053a40d55f4071d64111598f898c.tar.gz
master-31e0f0ae-8c6556049763053a40d55f4071d64111598f898c.tar.bz2
master-31e0f0ae-8c6556049763053a40d55f4071d64111598f898c.zip
imx6: add Gateworks GW551x support
Upstream patch: e9d6d6b62f306ba83e1441af5daf2809a6167474 Add support for the Gateworks GW5510 board featuring: * i.MX6 SoC * up to 512MB DDR3 * up to 2GB NAND flash * 1x miniPCIe socket (with USB) * HDMI out (micro-HDMI) * HDMI in (micro-HDMI) (currently supported by only vendor kernel) * TTL level I/O (supported by GW16111 breakout board): * I2C * 2x UART * CAN * 2x DIO (GPIO/PWM) * USB OTG Also add support to OpenWrt build system Signed-off-by: Tim Harvey <tharvey@gateworks.com> Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com> SVN-Revision: 47505
Diffstat (limited to 'target/linux/imx6/profiles')
-rw-r--r--target/linux/imx6/profiles/120-gateworks.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/imx6/profiles/120-gateworks.mk b/target/linux/imx6/profiles/120-gateworks.mk
index 115021af9c..735538409b 100644
--- a/target/linux/imx6/profiles/120-gateworks.mk
+++ b/target/linux/imx6/profiles/120-gateworks.mk
@@ -41,12 +41,14 @@ VENTANA_DTS:= \
imx6dl-gw52xx \
imx6dl-gw53xx \
imx6dl-gw54xx \
+ imx6dl-gw551x \
imx6dl-gw552x \
imx6q-gw51xx \
imx6q-gw52xx \
imx6q-gw53xx \
imx6q-gw54xx \
imx6q-gw5400-a \
+ imx6q-gw551x \
imx6q-gw552x
$(eval $(call Profile,VENTANA))