summaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-07-10 22:02:24 +0000
committerJohn Crispin <john@openwrt.org>2014-07-10 22:02:24 +0000
commitf88fde968988a30b93dcba7f0e1aca171cd61da2 (patch)
tree777254bbc6ea2f6e98e47a4f126995cc38a78bd1 /target/linux/imx6/image
parenta17a58e310e41829a634ac507477a0f6457a65d0 (diff)
downloadmaster-31e0f0ae-f88fde968988a30b93dcba7f0e1aca171cd61da2.tar.gz
master-31e0f0ae-f88fde968988a30b93dcba7f0e1aca171cd61da2.tar.bz2
master-31e0f0ae-f88fde968988a30b93dcba7f0e1aca171cd61da2.zip
imx6: put kernel and dtb into rootfs by default
this will make the rc1 images boot with the default config. Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 41578
Diffstat (limited to 'target/linux/imx6/image')
-rw-r--r--target/linux/imx6/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 1c68cb0e40..b07dd4fc8c 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -42,9 +42,9 @@ endef
define Image/InstallKernel/Template
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL)$(CONFIG_TARGET_imx6_VENTANA),)
$(INSTALL_DIR) $(TARGET_DIR)/boot
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE)$(CONFIG_TARGET_imx6_VENTANA),)
$(CP) $(BIN_DIR)/$(IMG_PREFIX)-uImage $(TARGET_DIR)/boot/
ln -sf $(IMG_PREFIX)-uImage $(TARGET_DIR)/boot/uImage
endif
@@ -59,7 +59,7 @@ define Image/InstallKernel/Template
endif
endif
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB)$(CONFIG_TARGET_imx6_VENTANA),)
$(INSTALL_DIR) $(TARGET_DIR)/boot
$(foreach dts,$(shell echo $(1)), \
$(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(dts).dtb $(TARGET_DIR)/boot/ ; \