summaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/image
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-05-17 20:03:22 +0200
committerJohn Crispin <john@phrozen.org>2016-05-23 11:03:23 +0200
commit9e41c3f54e3c476a4f3153bd7ee03ab43f6092ef (patch)
tree1bf5ec4edc2e5a461e5bf334828b0418d0e1cbe4 /target/linux/imx6/image
parent296543099962be9d0896655586709249094624bd (diff)
downloadmaster-31e0f0ae-9e41c3f54e3c476a4f3153bd7ee03ab43f6092ef.tar.gz
master-31e0f0ae-9e41c3f54e3c476a4f3153bd7ee03ab43f6092ef.tar.bz2
master-31e0f0ae-9e41c3f54e3c476a4f3153bd7ee03ab43f6092ef.zip
imx6: move profile definitions to the image/Makefile
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/imx6/image')
-rw-r--r--target/linux/imx6/image/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 584ac7a060..931076f914 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -116,7 +116,8 @@ endef
DEVICE_VARS += DEVICE_DTS
define Device/ventana
- PROFILES = Generic VENTANA
+ PROFILES := Generic VENTANA
+ DEVICE_TITLE := Gateworks Ventana family
DEVICE_DTS:= \
imx6dl-gw51xx \
imx6dl-gw52xx \
@@ -131,16 +132,24 @@ define Device/ventana
imx6q-gw5400-a \
imx6q-gw551x \
imx6q-gw552x
+ DEVICE_PACKAGES := kmod-thermal-imx kmod-sky2 kmod-usb-chipidea-imx kmod-usb-mxs-phy \
+ kmod-sound-core kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
+ kmod-can kmod-can-flexcan kmod-can-raw \
+ kmod-rtc-ds1672 kmod-gpio-pca953x kmod-hwmon-gsc kmod-eeprom-at24 \
+ kmod-leds-gpio kmod-pps-gpio kmod-gw16083 \
+ kobs-ng
IMAGES := nand_normal.ubi nand_large.ubi bootfs.tar.gz
IMAGE/nand_normal.ubi := ubi-boot-overlay normal 2048 124KiB 128KiB 8124
IMAGE/nand_large.ubi := ubi-boot-overlay large 4096 248KiB 256KiB 8124
IMAGE/bootfs.tar.gz := bootfs.tar.gz
- IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1)-$$(2)
+ IMAGE_NAME := $$(IMAGE_PREFIX)-$$(1)-$$(2)
endef
define Device/wandboard
- PROFILES = Generic IMX6DL_WANDBOARD
+ PROFILES := Generic IMX6DL_WANDBOARD
+ DEVICE_TITLE := Wandboard Dual
DEVICE_DTS := imx6dl-wandboard
+ DEVICE_PACKAGES := kmod-thermal-imx kmod-usb-chipidea-imx kmod-usb-mxs-phy
endef
TARGET_DEVICES += \