summaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/image
diff options
context:
space:
mode:
authorTim Harvey <tharvey@gateworks.com>2016-09-01 07:49:28 -0700
committerFelix Fietkau <nbd@nbd.name>2016-09-04 13:36:10 +0200
commit3314bcf7152767d45785882f586832adcd2a5723 (patch)
tree91779c0a7c0eddec144d3283413f8ccffef48163 /target/linux/imx6/image
parenta4b86b292a0bce95b9874d6c757a709c5a5269b4 (diff)
downloadmaster-31e0f0ae-3314bcf7152767d45785882f586832adcd2a5723.tar.gz
master-31e0f0ae-3314bcf7152767d45785882f586832adcd2a5723.tar.bz2
master-31e0f0ae-3314bcf7152767d45785882f586832adcd2a5723.zip
imx6: add GW553x support
The Gateworks Ventana GW553x is a single-board computer based on the NXP IMX6 SoC with the following features: * IMX6 DualLite Soc (supports IMX6S,IMX6DL,IMX6Q) * small form factor (35x70mm) * 512MB DDR3 DRAM (2x32bit) (options up to 2GB) * 256MB NAND flash (4GB option) * Gateworks System Controller: - hardware watchdog - hardware monitor - pushbutton controller - EEPROM storage - power control * JTAG programmable * 1x miniPCI socket (with PCIe, USB, SIM) * 1x microSD socket * 1x SIM socket * Inertial Module (LSM9DS1 9DOF: 3x acc, 3x rate, 3x mag) * analog CVBS video in * GPS (optional uBlox EVA-M8M) * Application headers: - 2x TTL UART (TX/RX) - 4x TTL GPIO (3x configurable as PWM) - 3x CVBS Analog video input (1x decoder with 3x selectable inputs) * Front panel connectors: * micro-HDMI audio/video out - 1x user programmable LED - 1x configurable user pushbutton - 1x USB OTG See http://www.gateworks.com for more info Signed-off-by: Tim Harvey <tharvey@gateworks.com>
Diffstat (limited to 'target/linux/imx6/image')
-rw-r--r--target/linux/imx6/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 2cd257d0a4..7893e0613c 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -84,7 +84,8 @@ define Device/ventana
imx6q-gw54xx \
imx6q-gw5400-a \
imx6q-gw551x \
- imx6q-gw552x
+ imx6q-gw552x \
+ imx6q-gw553x
DEVICE_PACKAGES := kmod-thermal-imx kmod-sky2 kmod-usb-chipidea-imx kmod-usb-mxs-phy \
kmod-sound-core kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
kmod-can kmod-can-flexcan kmod-can-raw \