summaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-02-27 22:41:40 +0000
committerLuka Perkov <luka@openwrt.org>2014-02-27 22:41:40 +0000
commitf7f117b88df3728c116902c29b04b59b38600633 (patch)
treecef53c1c1537bf3e420730f6056945d13fefcfbc /target/linux/imx6/Makefile
parent6752d4cb08b734235bd7978424087514623696b0 (diff)
downloadmaster-31e0f0ae-f7f117b88df3728c116902c29b04b59b38600633.tar.gz
master-31e0f0ae-f7f117b88df3728c116902c29b04b59b38600633.tar.bz2
master-31e0f0ae-f7f117b88df3728c116902c29b04b59b38600633.zip
imx6: optimize for NEON FPU hardware
The IMX6 SoC uses an ARM Cortext-A9 which has both NEON and VFPv3 hardware blocks. This will tune gcc to use neon instead of vfpv3 which will outperform VFPv3. Signed-off-by: Tim Harvey <tharvey@gateworks.com> SVN-Revision: 39760
Diffstat (limited to 'target/linux/imx6/Makefile')
-rw-r--r--target/linux/imx6/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/imx6/Makefile b/target/linux/imx6/Makefile
index cee5b45423..688e355393 100644
--- a/target/linux/imx6/Makefile
+++ b/target/linux/imx6/Makefile
@@ -11,7 +11,7 @@ BOARD:=imx6
BOARDNAME:=Freescale i.MX 6 Series
FEATURES:=audio display fpu gpio pcie rtc usb usbgadget squashfs targz ubifs
CPU_TYPE:=cortex-a9
-CPU_SUBTYPE:=vfpv3
+CPU_SUBTYPE:=neon
MAINTAINER:=Luka Perkov <luka@openwrt.org>
LINUX_VERSION:=3.10.32