summaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-02-27 22:41:39 +0000
committerLuka Perkov <luka@openwrt.org>2014-02-27 22:41:39 +0000
commit6752d4cb08b734235bd7978424087514623696b0 (patch)
treec41b5bb1e83d6491e3f2fe8b2a60c269bd645262 /target/linux/imx6/Makefile
parent95c97bf201b863723f6335d70a66b543e40f7398 (diff)
downloadmaster-31e0f0ae-6752d4cb08b734235bd7978424087514623696b0.tar.gz
master-31e0f0ae-6752d4cb08b734235bd7978424087514623696b0.tar.bz2
master-31e0f0ae-6752d4cb08b734235bd7978424087514623696b0.zip
imx6: enable FPU for hard float
The OpenWrt build system uses MACHINE_FEATURES of fpu to set the HAS_FPU which in turn sets the default of CONFIG_SOFT_FLOAT as well as uClibc configuration. As the IMX6 SoC has both vfpv3 and NEON hardware support we want to add fpu to the feature list. This will default the IMX6 target to use -mfloat-abi=hard which will the be most efficient use of floating point. When switching to hard float, we also need to enable VFP support in the kernel. Signed-off-by: Tim Harvey <tharvey@gateworks.com> SVN-Revision: 39759
Diffstat (limited to 'target/linux/imx6/Makefile')
-rw-r--r--target/linux/imx6/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/imx6/Makefile b/target/linux/imx6/Makefile
index 9ae1a4b4db..cee5b45423 100644
--- a/target/linux/imx6/Makefile
+++ b/target/linux/imx6/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=imx6
BOARDNAME:=Freescale i.MX 6 Series
-FEATURES:=audio display gpio pcie rtc usb usbgadget squashfs targz ubifs
+FEATURES:=audio display fpu gpio pcie rtc usb usbgadget squashfs targz ubifs
CPU_TYPE:=cortex-a9
CPU_SUBTYPE:=vfpv3
MAINTAINER:=Luka Perkov <luka@openwrt.org>