summaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-05-29 01:27:29 +0000
committerLuka Perkov <luka@openwrt.org>2013-05-29 01:27:29 +0000
commit4b21af426836d619f3251c90fc26475f6fee2fc5 (patch)
tree1617e076fb12470b9fbdd0f7a86ebd1f157b3f19 /target/linux/imx6/Makefile
parent846e3d40a02bb40f22dba03900ff79c085f4219d (diff)
downloadmaster-31e0f0ae-4b21af426836d619f3251c90fc26475f6fee2fc5.tar.gz
master-31e0f0ae-4b21af426836d619f3251c90fc26475f6fee2fc5.tar.bz2
master-31e0f0ae-4b21af426836d619f3251c90fc26475f6fee2fc5.zip
imx6: add new target
SVN-Revision: 36753
Diffstat (limited to 'target/linux/imx6/Makefile')
-rw-r--r--target/linux/imx6/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/imx6/Makefile b/target/linux/imx6/Makefile
new file mode 100644
index 0000000000..e866c0bb9b
--- /dev/null
+++ b/target/linux/imx6/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=imx6
+BOARDNAME:=Freescale i.MX 6 Series
+FEATURES:=audio display gpio pcie usb usbgadget squashfs targz
+CFLAGS:=-Os -pipe -mtune=cortex-a9 -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
+MAINTAINER:=Luka Perkov <luka@openwrt.org>
+
+LINUX_VERSION:=3.10-rc3
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="zImage dtbs"
+
+DEFAULT_PACKAGES +=
+
+$(eval $(call BuildTarget))