summaryrefslogtreecommitdiffstats
path: root/target/linux/imx23/profiles
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2013-07-04 22:25:26 +0000
committerZoltan Herpai <wigyori@uid0.hu>2013-07-04 22:25:26 +0000
commitde17203c855d17916e167d2889e3141f3f69dbb7 (patch)
tree56f08d943760cac0d19adf40955505bec6e9bb46 /target/linux/imx23/profiles
parent00b5a145677ac890f694898a8d095ad10574abdb (diff)
downloadmaster-31e0f0ae-de17203c855d17916e167d2889e3141f3f69dbb7.tar.gz
master-31e0f0ae-de17203c855d17916e167d2889e3141f3f69dbb7.tar.bz2
master-31e0f0ae-de17203c855d17916e167d2889e3141f3f69dbb7.zip
imx23: bump kernel to 3.10
- fix BOARDNAME - add profile for Olinuxino boards - prep image Makefile for u-boot inclusion, separate out bootlet build - update kernel config to reflect updated chipidea requirements - update rtc/watchdog config Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> SVN-Revision: 37175
Diffstat (limited to 'target/linux/imx23/profiles')
-rw-r--r--target/linux/imx23/profiles/01-olinuxino.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/imx23/profiles/01-olinuxino.mk b/target/linux/imx23/profiles/01-olinuxino.mk
new file mode 100644
index 0000000000..45986531ad
--- /dev/null
+++ b/target/linux/imx23/profiles/01-olinuxino.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/olinuxino
+ NAME:=Olimex Olinuxino boards
+ PACKAGES += imx-bootlets kmod-usb-mxs-phy kmod-usb-net kmod-usb-net-smsc95xx \
+ kmod-gpio-mcp23s08 kmod-leds-gpio kmod-ledtrig-heartbeat kmod-rtc-stmp3xxx
+endef
+
+define Profile/olinuxino/Description
+ Olimex Olinuxino boards
+endef
+$(eval $(call Profile,olinuxino))
+