summaryrefslogtreecommitdiffstats
path: root/target/linux/imx23/Makefile
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2013-06-27 10:12:03 +0000
committerZoltan Herpai <wigyori@uid0.hu>2013-06-27 10:12:03 +0000
commite5c7a93d71e14cb3fcc8539e4f2560402ff59c34 (patch)
tree0540a9fec23177f1894d906f43392b0a4385b2ee /target/linux/imx23/Makefile
parent1761b7b370b91bb2e9855dff5818cd503ea7f721 (diff)
downloadmaster-31e0f0ae-e5c7a93d71e14cb3fcc8539e4f2560402ff59c34.tar.gz
master-31e0f0ae-e5c7a93d71e14cb3fcc8539e4f2560402ff59c34.tar.bz2
master-31e0f0ae-e5c7a93d71e14cb3fcc8539e4f2560402ff59c34.zip
imx23: add new target for i.MX233-based boards
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> SVN-Revision: 37038
Diffstat (limited to 'target/linux/imx23/Makefile')
-rw-r--r--target/linux/imx23/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/imx23/Makefile b/target/linux/imx23/Makefile
new file mode 100644
index 0000000000..4aacb4918b
--- /dev/null
+++ b/target/linux/imx23/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=imx23
+BOARDNAME:=Olinuxino i.MX233
+FEATURES:=ext4 rtc usb gpio
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
+MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
+LINUX_VERSION:=3.9.4
+KERNELNAME:="zImage dtbs"
+DEPENDS:=+imx-bootlets
+
+define Target/Description
+ Support for Olimex Olinuxino boards
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += dnsmasq imx-bootlets kmod-usb-chipidea kmod-usb-net kmod-usb-net-smsc95xx \
+ kmod-wdt-stmp3xxx kmod-gpio-mcp23s08 kmod-leds-gpio kmod-ledtrig-heartbeat
+
+$(eval $(call BuildTarget))