summaryrefslogtreecommitdiffstats
path: root/target/linux/ifxmips/patches-2.6.30/160-led.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2009-10-08 22:24:49 +0000
committerJohn Crispin <john@openwrt.org>2009-10-08 22:24:49 +0000
commitaaf52c0c7d2db474a009706cdabc48f6ca90a0aa (patch)
treedeed8a92365d669ba9a070fd5b8afad5e0a6eaa3 /target/linux/ifxmips/patches-2.6.30/160-led.patch
parent76ff676a1e403fdb7a14dc199db07b052d9da9b3 (diff)
downloadmaster-31e0f0ae-aaf52c0c7d2db474a009706cdabc48f6ca90a0aa.tar.gz
master-31e0f0ae-aaf52c0c7d2db474a009706cdabc48f6ca90a0aa.tar.bz2
master-31e0f0ae-aaf52c0c7d2db474a009706cdabc48f6ca90a0aa.zip
ifxmips: move header files, split up patches, rename some files
SVN-Revision: 18010
Diffstat (limited to 'target/linux/ifxmips/patches-2.6.30/160-led.patch')
-rw-r--r--target/linux/ifxmips/patches-2.6.30/160-led.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/ifxmips/patches-2.6.30/160-led.patch b/target/linux/ifxmips/patches-2.6.30/160-led.patch
new file mode 100644
index 0000000000..aca11d5535
--- /dev/null
+++ b/target/linux/ifxmips/patches-2.6.30/160-led.patch
@@ -0,0 +1,29 @@
+Index: linux-2.6.30.5/drivers/leds/Kconfig
+===================================================================
+--- linux-2.6.30.5.orig/drivers/leds/Kconfig 2009-09-02 18:22:49.000000000 +0200
++++ linux-2.6.30.5/drivers/leds/Kconfig 2009-09-02 18:29:51.000000000 +0200
+@@ -227,6 +227,12 @@
+ This option enables support for BD2802GU RGB LED driver chips
+ accessed via the I2C bus.
+
++config LEDS_IFXMIPS
++ tristate "LED Support for IFXMIPS LEDs"
++ depends on LEDS_CLASS && IFXMIPS
++ help
++ This option enables support for the CM-X270 LEDs.
++
+ comment "LED Triggers"
+
+ config LEDS_TRIGGERS
+Index: linux-2.6.30.5/drivers/leds/Makefile
+===================================================================
+--- linux-2.6.30.5.orig/drivers/leds/Makefile 2009-09-02 18:22:49.000000000 +0200
++++ linux-2.6.30.5/drivers/leds/Makefile 2009-09-02 18:31:23.000000000 +0200
+@@ -27,6 +27,7 @@
+ obj-$(CONFIG_LEDS_DA903X) += leds-da903x.o
+ obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
+ obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
++obj-$(CONFIG_LEDS_IFXMIPS) += leds-ifxmips.o
+
+ # LED SPI Drivers
+ obj-$(CONFIG_LEDS_DAC124S085) += leds-dac124s085.o