summaryrefslogtreecommitdiffstats
path: root/target/linux/ifxmips/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2007-12-20 22:29:45 +0000
committerJohn Crispin <john@openwrt.org>2007-12-20 22:29:45 +0000
commitb998d4fa51609b2b1e3a91deb118918c301dd7e8 (patch)
tree27cb7ef40b5d90fbcf3fe736719e92367a3990e3 /target/linux/ifxmips/image
parent498a2e30702494fd3171fdc813bee410cc94661a (diff)
downloadmaster-31e0f0ae-b998d4fa51609b2b1e3a91deb118918c301dd7e8.tar.gz
master-31e0f0ae-b998d4fa51609b2b1e3a91deb118918c301dd7e8.tar.bz2
master-31e0f0ae-b998d4fa51609b2b1e3a91deb118918c301dd7e8.zip
move danube folder to ifxmips, to allow future integration of the other chips
SVN-Revision: 9815
Diffstat (limited to 'target/linux/ifxmips/image')
-rw-r--r--target/linux/ifxmips/image/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/target/linux/ifxmips/image/Makefile b/target/linux/ifxmips/image/Makefile
new file mode 100644
index 0000000000..41082982b9
--- /dev/null
+++ b/target/linux/ifxmips/image/Makefile
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.lzma
+ mkimage -A mips -O linux -T kernel -a 0x80002000 -C lzma -e \
+ 0x80002000 \
+ -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/vmlinux.lzma $(KDIR)/uImage
+
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-uImage
+endef
+
+define Image/Build/squashfs
+ cat $(KDIR)/uImage $(KDIR)/root.$(1) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).image
+ $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).image)
+endef
+
+define Image/Build/jffs2-64k
+ dd if=$(KDIR)/uImage of=$(KDIR)/uImage.$(1) bs=64k conv=sync
+ cat $(KDIR)/uImage.$(1) $(KDIR)/root.$(1) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).image
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+$(eval $(call BuildImage))