summaryrefslogtreecommitdiffstats
path: root/target/linux/ifxmips/image/u-boot/files/board/danube/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2008-05-11 14:13:15 +0000
committerJohn Crispin <john@openwrt.org>2008-05-11 14:13:15 +0000
commit4d4f7d4c845901f0353c492f05c4f837dfd1e049 (patch)
tree8cad938f65f89fb196fadb1ebae436282f4ee313 /target/linux/ifxmips/image/u-boot/files/board/danube/Makefile
parent2b05ed626c650657e29575f209ea80e6553f8a55 (diff)
downloadmaster-31e0f0ae-4d4f7d4c845901f0353c492f05c4f837dfd1e049.tar.gz
master-31e0f0ae-4d4f7d4c845901f0353c492f05c4f837dfd1e049.tar.bz2
master-31e0f0ae-4d4f7d4c845901f0353c492f05c4f837dfd1e049.zip
add u-boot sources for danube
SVN-Revision: 11108
Diffstat (limited to 'target/linux/ifxmips/image/u-boot/files/board/danube/Makefile')
-rw-r--r--target/linux/ifxmips/image/u-boot/files/board/danube/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/target/linux/ifxmips/image/u-boot/files/board/danube/Makefile b/target/linux/ifxmips/image/u-boot/files/board/danube/Makefile
new file mode 100644
index 0000000000..0163fd96f8
--- /dev/null
+++ b/target/linux/ifxmips/image/u-boot/files/board/danube/Makefile
@@ -0,0 +1,41 @@
+#
+# (C) Copyright 2003
+# Wolfgang Denk, DENX Software Engineering, wd@denx.de.
+#
+# See file CREDITS for list of people who contributed to this
+# project.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston,
+# MA 02111-1307 USA
+#
+
+include $(TOPDIR)/config.mk
+
+LIB = lib$(BOARD).a
+
+OBJS = $(BOARD).o flash.o
+SOBJS = lowlevel_init.o pmuenable.o
+
+$(LIB): .depend $(OBJS) $(SOBJS)
+ $(AR) crv $@ $^
+
+#########################################################################
+
+.depend: Makefile $(SOBJS:.o=.S) $(OBJS:.o=.c)
+ $(CC) -M $(CFLAGS) $(SOBJS:.o=.S) $(OBJS:.o=.c) > $@
+
+sinclude .depend
+
+#########################################################################