summaryrefslogtreecommitdiffstats
path: root/target/linux/ifxmips/image/u-boot/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-06-28 19:53:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-06-28 19:53:41 +0000
commit783bb0e81c700fb0b71420854ae1d7175adf666b (patch)
tree67f797884968d898c9873b3c3dc7facff9064351 /target/linux/ifxmips/image/u-boot/Makefile
parentf5bdb5432fef3a596c4b87ed45f0ec00a637a622 (diff)
downloadmaster-31e0f0ae-783bb0e81c700fb0b71420854ae1d7175adf666b.tar.gz
master-31e0f0ae-783bb0e81c700fb0b71420854ae1d7175adf666b.tar.bz2
master-31e0f0ae-783bb0e81c700fb0b71420854ae1d7175adf666b.zip
move ifxmips uboot to package/
SVN-Revision: 11601
Diffstat (limited to 'target/linux/ifxmips/image/u-boot/Makefile')
-rw-r--r--target/linux/ifxmips/image/u-boot/Makefile34
1 files changed, 0 insertions, 34 deletions
diff --git a/target/linux/ifxmips/image/u-boot/Makefile b/target/linux/ifxmips/image/u-boot/Makefile
deleted file mode 100644
index dcba5ac45a..0000000000
--- a/target/linux/ifxmips/image/u-boot/Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
-#
-# Copyright (C) 2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=u-boot
-PKG_VERSION:=1.1.5
-PKG_RELEASE:=1
-
-PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=579707c8ecbf1ab4127285d2aac2a9ee
-PKG_CAT:=bzcat
-
-include $(INCLUDE_DIR)/package.mk
-
-define Build/Compile
- cp -r ./files/* $(PKG_BUILD_DIR)
- find $(PKG_BUILD_DIR) -name .svn | $(XARGS) rm -rf
- cd $(PKG_BUILD_DIR);chmod a+x build_danube.sh;./build_danube.sh
-endef
-
-define Build/InstallDev
- mkdir -p $(BIN_DIR)
- dd if=$(PKG_BUILD_DIR)/u-boot.ifx of=$(BIN_DIR)/u-boot.ifx bs=64k conv=sync
-endef
-
-$(eval $(call Build/DefaultTargets))