summaryrefslogtreecommitdiffstats
path: root/target/linux/ifxmips/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2008-05-11 14:13:15 +0000
committerJohn Crispin <john@openwrt.org>2008-05-11 14:13:15 +0000
commit4d4f7d4c845901f0353c492f05c4f837dfd1e049 (patch)
tree8cad938f65f89fb196fadb1ebae436282f4ee313 /target/linux/ifxmips/image/Makefile
parent2b05ed626c650657e29575f209ea80e6553f8a55 (diff)
downloadmaster-31e0f0ae-4d4f7d4c845901f0353c492f05c4f837dfd1e049.tar.gz
master-31e0f0ae-4d4f7d4c845901f0353c492f05c4f837dfd1e049.tar.bz2
master-31e0f0ae-4d4f7d4c845901f0353c492f05c4f837dfd1e049.zip
add u-boot sources for danube
SVN-Revision: 11108
Diffstat (limited to 'target/linux/ifxmips/image/Makefile')
-rw-r--r--target/linux/ifxmips/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ifxmips/image/Makefile b/target/linux/ifxmips/image/Makefile
index 41082982b9..94eefe8700 100644
--- a/target/linux/ifxmips/image/Makefile
+++ b/target/linux/ifxmips/image/Makefile
@@ -7,6 +7,14 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+define Build/Clean
+ $(MAKE) -C u-boot clean
+endef
+
+define Build/Compile
+ $(MAKE) -C u-boot compile
+endef
+
define Image/BuildKernel
$(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.lzma
mkimage -A mips -O linux -T kernel -a 0x80002000 -C lzma -e \