summaryrefslogtreecommitdiffstats
path: root/target/linux/goldfish/image/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
commite2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f (patch)
treef8563604e7685c30b0a2a675ca80379a34114565 /target/linux/goldfish/image/Makefile
parent040c06438896144dfe148910f922a0d9bb0058b0 (diff)
downloadmaster-31e0f0ae-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.tar.gz
master-31e0f0ae-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.tar.bz2
master-31e0f0ae-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.zip
define a shared IMG_PREFIX variable used as a basename for image files, it contains board & subtarget infos (if appropriate) allowing subtargets to share the same bin directory without overwriting each other's files
SVN-Revision: 20834
Diffstat (limited to 'target/linux/goldfish/image/Makefile')
-rw-r--r--target/linux/goldfish/image/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/target/linux/goldfish/image/Makefile b/target/linux/goldfish/image/Makefile
index bf871fb2ae..6cd57ba52c 100644
--- a/target/linux/goldfish/image/Makefile
+++ b/target/linux/goldfish/image/Makefile
@@ -1,25 +1,22 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
JFFS2_BLOCKSIZE=124k
JFFS2OPTS += -n -s 2048
-_PREFIX=openwrt-goldfish-
-
define Image/BuildKernel
$(TARGET_CROSS)objcopy -O binary -R .note -R .comment -S \
- $(LINUX_DIR)/arch/arm/boot/compressed/vmlinux $(BIN_DIR)/$(_PREFIX)kernel.bin
+ $(LINUX_DIR)/arch/arm/boot/compressed/vmlinux $(BIN_DIR)/$(IMG_PREFIX)-kernel.bin
$(if $(CONFIG_TARGET_ROOTFS_INITRAMFS), \
$(CP) $(LINUX_DIR)/usr/initramfs_data.cpio.gz, \
gzip -c < $(LINUX_DIR)/usr/initramfs_data.cpio > \
- ) $(BIN_DIR)/$(_PREFIX)ramdisk.bin
+ ) $(BIN_DIR)/$(IMG_PREFIX)-ramdisk.bin
$(CP) ./run-emulator.sh $(BIN_DIR)/
endef
@@ -27,12 +24,12 @@ define Image/Build/jffs2-124k
$(CP) ./ubinize.cfg $(KDIR)/
(cd $(KDIR); \
ubinize \
- -o $(BIN_DIR)/$(_PREFIX)$(1).img \
+ -o $(BIN_DIR)/$(IMG_PREFIX)-$(1).img \
-p 128KiB -m 2KiB -s 2KiB ubinize.cfg; \
)
nand_ecc \
- $(BIN_DIR)/$(_PREFIX)$(1).img \
- $(BIN_DIR)/$(_PREFIX)system.bin
+ $(BIN_DIR)/$(IMG_PREFIX)-$(1).img \
+ $(BIN_DIR)/$(IMG_PREFIX)-system.bin
endef
define Image/Build