summaryrefslogtreecommitdiffstats
path: root/target/linux/generic
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-08-04 22:42:28 +0200
committerFelix Fietkau <nbd@nbd.name>2016-08-04 22:53:01 +0200
commit002b45368792a04e480db3ca3f23a4aefb787670 (patch)
treea3102c435f29d0f1131a30c4ade5016c61b5cbec /target/linux/generic
parentecf7671b769fe96f7b5134be442089f8bdba55d2 (diff)
downloadmaster-31e0f0ae-002b45368792a04e480db3ca3f23a4aefb787670.tar.gz
master-31e0f0ae-002b45368792a04e480db3ca3f23a4aefb787670.tar.bz2
master-31e0f0ae-002b45368792a04e480db3ca3f23a4aefb787670.zip
kernel: add -mtune=34kc to MIPS CFLAGS when building for mips32r2
This provides a good tradeoff across at least 24Kc-74Kc, while also producing smaller code. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/generic')
-rw-r--r--target/linux/generic/patches-4.4/308-mips32r2_tune.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.4/308-mips32r2_tune.patch b/target/linux/generic/patches-4.4/308-mips32r2_tune.patch
new file mode 100644
index 0000000000..f4ab89ef28
--- /dev/null
+++ b/target/linux/generic/patches-4.4/308-mips32r2_tune.patch
@@ -0,0 +1,17 @@
+Add -mtune=34kc to MIPS CFLAGS when building for mips32r2
+This provides a good tradeoff across at least 24Kc-74Kc, while also
+producing smaller code.
+
+Signed-off-by: Felix Fietkau <nbd@nbd.name>
+
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -145,7 +145,7 @@ cflags-$(CONFIG_CPU_R4X00) += -march=r46
+ cflags-$(CONFIG_CPU_TX49XX) += -march=r4600 -Wa,--trap
+ cflags-$(CONFIG_CPU_MIPS32_R1) += $(call cc-option,-march=mips32,-mips32 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
+ -Wa,-mips32 -Wa,--trap
+-cflags-$(CONFIG_CPU_MIPS32_R2) += $(call cc-option,-march=mips32r2,-mips32r2 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
++cflags-$(CONFIG_CPU_MIPS32_R2) += $(call cc-option,-march=mips32r2 -mtune=34kc,-mips32r2 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
+ -Wa,-mips32r2 -Wa,--trap
+ cflags-$(CONFIG_CPU_MIPS32_R6) += -march=mips32r6 -Wa,--trap
+ cflags-$(CONFIG_CPU_MIPS64_R1) += $(call cc-option,-march=mips64,-mips64 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS64) \