summaryrefslogtreecommitdiffstats
path: root/target/linux/generic
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-21 17:56:18 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-21 17:56:18 +0000
commit2e62ff9320035e47a945cac48b16a4428844e5d7 (patch)
treeac76dc579b8e4de976d8d2b7bcce038619ff4e57 /target/linux/generic
parent2f2ed5c5c161d77ae94f70c07caaeb1edbb419df (diff)
downloadmaster-31e0f0ae-2e62ff9320035e47a945cac48b16a4428844e5d7.tar.gz
master-31e0f0ae-2e62ff9320035e47a945cac48b16a4428844e5d7.tar.bz2
master-31e0f0ae-2e62ff9320035e47a945cac48b16a4428844e5d7.zip
kernel/3.10: add partition parser for Seama firmwares
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38114
Diffstat (limited to 'target/linux/generic')
-rw-r--r--target/linux/generic/config-3.101
-rw-r--r--target/linux/generic/files/drivers/mtd/mtdsplit_seama.c102
-rw-r--r--target/linux/generic/patches-3.10/408-mtd-hook-mtdsplit_seama-into-Kbuild.patch23
3 files changed, 126 insertions, 0 deletions
diff --git a/target/linux/generic/config-3.10 b/target/linux/generic/config-3.10
index a4e4665a1b..16f4235520 100644
--- a/target/linux/generic/config-3.10
+++ b/target/linux/generic/config-3.10
@@ -1935,6 +1935,7 @@ CONFIG_MTD_ROOTFS_SPLIT=y
CONFIG_MTD_SPLIT=y
# CONFIG_MTD_SPLIT_FIRMWARE is not set
CONFIG_MTD_SPLIT_FIRMWARE_NAME="firmware"
+# CONFIG_MTD_SPLIT_SEAMA_FW is not set
# CONFIG_MTD_SPLIT_SQUASHFS_ROOT is not set
# CONFIG_MTD_SPLIT_UIMAGE_FW is not set
# CONFIG_MTD_SST25L is not set
diff --git a/target/linux/generic/files/drivers/mtd/mtdsplit_seama.c b/target/linux/generic/files/drivers/mtd/mtdsplit_seama.c
new file mode 100644
index 0000000000..7a2dc7d855
--- /dev/null
+++ b/target/linux/generic/files/drivers/mtd/mtdsplit_seama.c
@@ -0,0 +1,102 @@
+/*
+ * Copyright (C) 2013 Gabor Juhos <juhosg@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ *
+ */
+
+#include <linux/module.h>
+#include <linux/init.h>
+#include <linux/kernel.h>
+#include <linux/slab.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/byteorder/generic.h>
+
+#include "mtdsplit.h"
+
+#define SEAMA_MAGIC 0x5EA3A417
+#define SEAMA_NR_PARTS 2
+#define SEAMA_MIN_ROOTFS_OFFS 0x80000 /* 512KiB */
+
+struct seama_header {
+ __be32 magic; /* should always be SEAMA_MAGIC. */
+ __be16 reserved; /* reserved for */
+ __be16 metasize; /* size of the META data */
+ __be32 size; /* size of the image */
+};
+
+static int mtdsplit_parse_seama(struct mtd_info *master,
+ struct mtd_partition **pparts,
+ struct mtd_part_parser_data *data)
+{
+ struct seama_header hdr;
+ size_t hdr_len, retlen, kernel_size;
+ size_t rootfs_offset;
+ struct mtd_partition *parts;
+ int err;
+
+ hdr_len = sizeof(hdr);
+ err = mtd_read(master, 0, hdr_len, &retlen, (void *) &hdr);
+ if (err)
+ return err;
+
+ if (retlen != hdr_len)
+ return -EIO;
+
+ /* sanity checks */
+ if (be32_to_cpu(hdr.magic) != SEAMA_MAGIC)
+ return -EINVAL;
+
+ kernel_size = hdr_len + be32_to_cpu(hdr.size) +
+ be16_to_cpu(hdr.metasize);
+ if (kernel_size > master->size)
+ return -EINVAL;
+
+ /* Find the rootfs after the kernel. */
+ err = mtd_check_rootfs_magic(master, kernel_size);
+ if (!err) {
+ rootfs_offset = kernel_size;
+ } else {
+ /*
+ * The size in the header might cover the rootfs as well.
+ * Start the search from an arbitrary offset.
+ */
+ err = mtd_find_rootfs_from(master, SEAMA_MIN_ROOTFS_OFFS,
+ master->size, &rootfs_offset);
+ if (err)
+ return err;
+ }
+
+ parts = kzalloc(SEAMA_NR_PARTS * sizeof(*parts), GFP_KERNEL);
+ if (!parts)
+ return -ENOMEM;
+
+ parts[0].name = KERNEL_PART_NAME;
+ parts[0].offset = 0;
+ parts[0].size = rootfs_offset;
+
+ parts[1].name = ROOTFS_PART_NAME;
+ parts[1].offset = rootfs_offset;
+ parts[1].size = master->size - rootfs_offset;
+
+ *pparts = parts;
+ return SEAMA_NR_PARTS;
+}
+
+static struct mtd_part_parser mtdsplit_seama_parser = {
+ .owner = THIS_MODULE,
+ .name = "seama-fw",
+ .parse_fn = mtdsplit_parse_seama,
+ .type = MTD_PARSER_TYPE_FIRMWARE,
+};
+
+static int
+mtdsplit_seama_init(void)
+{
+ return register_mtd_parser(&mtdsplit_seama_parser);
+}
+
+subsys_initcall(mtdsplit_seama_init);
diff --git a/target/linux/generic/patches-3.10/408-mtd-hook-mtdsplit_seama-into-Kbuild.patch b/target/linux/generic/patches-3.10/408-mtd-hook-mtdsplit_seama-into-Kbuild.patch
new file mode 100644
index 0000000000..016a9b6e4c
--- /dev/null
+++ b/target/linux/generic/patches-3.10/408-mtd-hook-mtdsplit_seama-into-Kbuild.patch
@@ -0,0 +1,23 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -50,6 +50,10 @@ config MTD_SPLIT_SQUASHFS_ROOT
+
+ comment "Firmware partition parsers"
+
++config MTD_SPLIT_SEAMA_FW
++ bool "Seama firmware parser"
++ select MTD_SPLIT
++
+ config MTD_SPLIT_UIMAGE_FW
+ bool "uImage based firmware partition parser"
+ select MTD_SPLIT
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -7,6 +7,7 @@ obj-$(CONFIG_MTD) += mtd.o
+ mtd-y := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
+
+ mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
++mtd-$(CONFIG_MTD_SPLIT_SEAMA_FW) += mtdsplit_seama.o
+ mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
+ mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
+