summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.3/970-remove-unsane-filenames-from-deps_initramfs-list.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2015-10-11 19:08:08 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2015-10-11 19:08:08 +0000
commitb5842aed82e0c9101e99ec4bcf5959b931e98989 (patch)
treef9749eb8ce7d61f284cc4d91bac5aafd07de8344 /target/linux/generic/patches-4.3/970-remove-unsane-filenames-from-deps_initramfs-list.patch
parent3d1a65adb41db2758827fe81f36d92ab61618ea3 (diff)
downloadmaster-31e0f0ae-b5842aed82e0c9101e99ec4bcf5959b931e98989.tar.gz
master-31e0f0ae-b5842aed82e0c9101e99ec4bcf5959b931e98989.tar.bz2
master-31e0f0ae-b5842aed82e0c9101e99ec4bcf5959b931e98989.zip
kernel: generic: add kernel 4.3
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 47182
Diffstat (limited to 'target/linux/generic/patches-4.3/970-remove-unsane-filenames-from-deps_initramfs-list.patch')
-rw-r--r--target/linux/generic/patches-4.3/970-remove-unsane-filenames-from-deps_initramfs-list.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.3/970-remove-unsane-filenames-from-deps_initramfs-list.patch b/target/linux/generic/patches-4.3/970-remove-unsane-filenames-from-deps_initramfs-list.patch
new file mode 100644
index 0000000000..ac13c9e673
--- /dev/null
+++ b/target/linux/generic/patches-4.3/970-remove-unsane-filenames-from-deps_initramfs-list.patch
@@ -0,0 +1,29 @@
+--- a/usr/Makefile
++++ b/usr/Makefile
+@@ -53,6 +53,8 @@ ifneq ($(wildcard $(obj)/.initramfs_data
+ include $(obj)/.initramfs_data.cpio.d
+ endif
+
++deps_initramfs_sane := $(foreach v,$(deps_initramfs),$(if $(findstring :,$(v)),,$(v)))
++
+ quiet_cmd_initfs = GEN $@
+ cmd_initfs = $(initramfs) -o $@ $(ramfs-args) $(ramfs-input)
+
+@@ -61,14 +63,14 @@ targets := initramfs_data.cpio.gz initra
+ initramfs_data.cpio.lzo initramfs_data.cpio.lz4 \
+ initramfs_data.cpio
+ # do not try to update files included in initramfs
+-$(deps_initramfs): ;
++$(deps_initramfs_sane): ;
+
+-$(deps_initramfs): klibcdirs
++$(deps_initramfs_sane): klibcdirs
+ # We rebuild initramfs_data.cpio if:
+ # 1) Any included file is newer then initramfs_data.cpio
+ # 2) There are changes in which files are included (added or deleted)
+ # 3) If gen_init_cpio are newer than initramfs_data.cpio
+ # 4) arguments to gen_initramfs.sh changes
+-$(obj)/initramfs_data.cpio$(suffix_y): $(obj)/gen_init_cpio $(deps_initramfs) klibcdirs
++$(obj)/initramfs_data.cpio$(suffix_y): $(obj)/gen_init_cpio $(deps_initramfs_sane) klibcdirs
+ $(Q)$(initramfs) -l $(ramfs-input) > $(obj)/.initramfs_data.cpio.d
+ $(call if_changed,initfs)