summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.3/725-phy_rtl8306.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2015-10-11 19:08:08 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2015-10-11 19:08:08 +0000
commitb5842aed82e0c9101e99ec4bcf5959b931e98989 (patch)
treef9749eb8ce7d61f284cc4d91bac5aafd07de8344 /target/linux/generic/patches-4.3/725-phy_rtl8306.patch
parent3d1a65adb41db2758827fe81f36d92ab61618ea3 (diff)
downloadmaster-31e0f0ae-b5842aed82e0c9101e99ec4bcf5959b931e98989.tar.gz
master-31e0f0ae-b5842aed82e0c9101e99ec4bcf5959b931e98989.tar.bz2
master-31e0f0ae-b5842aed82e0c9101e99ec4bcf5959b931e98989.zip
kernel: generic: add kernel 4.3
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 47182
Diffstat (limited to 'target/linux/generic/patches-4.3/725-phy_rtl8306.patch')
-rw-r--r--target/linux/generic/patches-4.3/725-phy_rtl8306.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.3/725-phy_rtl8306.patch b/target/linux/generic/patches-4.3/725-phy_rtl8306.patch
new file mode 100644
index 0000000000..803e770590
--- /dev/null
+++ b/target/linux/generic/patches-4.3/725-phy_rtl8306.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -166,6 +166,10 @@ config AR8216_PHY
+ select ETHERNET_PACKET_MANGLE
+ select SWCONFIG
+
++config RTL8306_PHY
++ tristate "Driver for Realtek RTL8306S switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ tristate "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -25,6 +25,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o ar8327.o
++obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed_phy.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o