summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.3/201-extra_optimization.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2015-10-11 19:08:08 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2015-10-11 19:08:08 +0000
commitb5842aed82e0c9101e99ec4bcf5959b931e98989 (patch)
treef9749eb8ce7d61f284cc4d91bac5aafd07de8344 /target/linux/generic/patches-4.3/201-extra_optimization.patch
parent3d1a65adb41db2758827fe81f36d92ab61618ea3 (diff)
downloadmaster-31e0f0ae-b5842aed82e0c9101e99ec4bcf5959b931e98989.tar.gz
master-31e0f0ae-b5842aed82e0c9101e99ec4bcf5959b931e98989.tar.bz2
master-31e0f0ae-b5842aed82e0c9101e99ec4bcf5959b931e98989.zip
kernel: generic: add kernel 4.3
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 47182
Diffstat (limited to 'target/linux/generic/patches-4.3/201-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-4.3/201-extra_optimization.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.3/201-extra_optimization.patch b/target/linux/generic/patches-4.3/201-extra_optimization.patch
new file mode 100644
index 0000000000..625210de06
--- /dev/null
+++ b/target/linux/generic/patches-4.3/201-extra_optimization.patch
@@ -0,0 +1,14 @@
+--- a/Makefile
++++ b/Makefile
+@@ -607,9 +607,9 @@ include arch/$(SRCARCH)/Makefile
+ KBUILD_CFLAGS += $(call cc-option,-fno-delete-null-pointer-checks,)
+
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+-KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,)
++KBUILD_CFLAGS += -Os $(EXTRA_OPTIMIZATION) $(call cc-disable-warning,maybe-uninitialized,)
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch $(EXTRA_OPTIMIZATION)
+ endif
+
+ # Tell gcc to never replace conditional load with a non-conditional one