summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.0/728-phy-rtl8367b.patch
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-02-23 22:59:53 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-02-23 22:59:53 +0000
commit1c063070cf6bc2b81674f60b6ad6ae0ee9b4152f (patch)
tree0a83cfa5ea98e519ade4fa7f4e8a859e26bd737c /target/linux/generic/patches-4.0/728-phy-rtl8367b.patch
parentad077832bfb03106a02b7be02b560c13e77d0436 (diff)
downloadmaster-31e0f0ae-1c063070cf6bc2b81674f60b6ad6ae0ee9b4152f.tar.gz
master-31e0f0ae-1c063070cf6bc2b81674f60b6ad6ae0ee9b4152f.tar.bz2
master-31e0f0ae-1c063070cf6bc2b81674f60b6ad6ae0ee9b4152f.zip
generic: early (incomplete!) 4.0 support
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 44511
Diffstat (limited to 'target/linux/generic/patches-4.0/728-phy-rtl8367b.patch')
-rw-r--r--target/linux/generic/patches-4.0/728-phy-rtl8367b.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.0/728-phy-rtl8367b.patch b/target/linux/generic/patches-4.0/728-phy-rtl8367b.patch
new file mode 100644
index 0000000000..2053b52b5d
--- /dev/null
+++ b/target/linux/generic/patches-4.0/728-phy-rtl8367b.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -276,6 +276,10 @@ config RTL8367_PHY
+ tristate "Driver for the Realtek RTL8367R/M switches"
+ select SWCONFIG
+
++config RTL8367B_PHY
++ tristate "Driver fot the Realtek RTL8367R-VB switch"
++ select SWCONFIG
++
+ endif # RTL8366_SMI
+
+ endif # PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -28,6 +28,7 @@ obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi
+ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
+ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
++obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed_phy.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o