summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.9/720-phy_adm6996.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-03-14 14:45:56 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-03-14 14:45:56 +0000
commitb2e63b8ea81fae72aef69649631cf491bac5306f (patch)
tree9a4bc7d83c339b4b842999287e3ae5e5d5d6734a /target/linux/generic/patches-3.9/720-phy_adm6996.patch
parent32f3b1e3582701ef6c8c248b9ad0a761c42bbc1b (diff)
downloadmaster-31e0f0ae-b2e63b8ea81fae72aef69649631cf491bac5306f.tar.gz
master-31e0f0ae-b2e63b8ea81fae72aef69649631cf491bac5306f.tar.bz2
master-31e0f0ae-b2e63b8ea81fae72aef69649631cf491bac5306f.zip
kernel: add support for 3.9-rc2
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 36008
Diffstat (limited to 'target/linux/generic/patches-3.9/720-phy_adm6996.patch')
-rw-r--r--target/linux/generic/patches-3.9/720-phy_adm6996.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.9/720-phy_adm6996.patch b/target/linux/generic/patches-3.9/720-phy_adm6996.patch
new file mode 100644
index 0000000000..65b206da3e
--- /dev/null
+++ b/target/linux/generic/patches-3.9/720-phy_adm6996.patch
@@ -0,0 +1,26 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -120,6 +120,13 @@ config MICREL_PHY
+ ---help---
+ Supports the KSZ9021, VSC8201, KS8001 PHYs.
+
++config ADM6996_PHY
++ tristate "Driver for ADM6996 switches"
++ select SWCONFIG
++ ---help---
++ Currently supports the ADM6996FC and ADM6996M switches.
++ Support for FC is very limited.
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -17,6 +17,7 @@ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
+ obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
+ obj-$(CONFIG_BCM87XX_PHY) += bcm87xx.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
++obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o