summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.9/500-yaffs-Kbuild-integration.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-03-14 14:45:56 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-03-14 14:45:56 +0000
commitb2e63b8ea81fae72aef69649631cf491bac5306f (patch)
tree9a4bc7d83c339b4b842999287e3ae5e5d5d6734a /target/linux/generic/patches-3.9/500-yaffs-Kbuild-integration.patch
parent32f3b1e3582701ef6c8c248b9ad0a761c42bbc1b (diff)
downloadmaster-31e0f0ae-b2e63b8ea81fae72aef69649631cf491bac5306f.tar.gz
master-31e0f0ae-b2e63b8ea81fae72aef69649631cf491bac5306f.tar.bz2
master-31e0f0ae-b2e63b8ea81fae72aef69649631cf491bac5306f.zip
kernel: add support for 3.9-rc2
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 36008
Diffstat (limited to 'target/linux/generic/patches-3.9/500-yaffs-Kbuild-integration.patch')
-rw-r--r--target/linux/generic/patches-3.9/500-yaffs-Kbuild-integration.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.9/500-yaffs-Kbuild-integration.patch b/target/linux/generic/patches-3.9/500-yaffs-Kbuild-integration.patch
new file mode 100644
index 0000000000..3940c1050e
--- /dev/null
+++ b/target/linux/generic/patches-3.9/500-yaffs-Kbuild-integration.patch
@@ -0,0 +1,18 @@
+--- a/fs/Kconfig
++++ b/fs/Kconfig
+@@ -39,6 +39,7 @@ source "fs/gfs2/Kconfig"
+ source "fs/ocfs2/Kconfig"
+ source "fs/btrfs/Kconfig"
+ source "fs/nilfs2/Kconfig"
++source "fs/yaffs2/Kconfig"
+
+ endif # BLOCK
+
+--- a/fs/Makefile
++++ b/fs/Makefile
+@@ -128,3 +128,5 @@ obj-$(CONFIG_F2FS_FS) += f2fs/
+ obj-y += exofs/ # Multiple modules
+ obj-$(CONFIG_CEPH_FS) += ceph/
+ obj-$(CONFIG_PSTORE) += pstore/
++obj-$(CONFIG_YAFFS_FS) += yaffs2/
++