summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.9/430-mtd_myloader_partition_parser.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2014-09-08 19:55:36 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2014-09-08 19:55:36 +0000
commit54cd991725079fdce550e86f2303ece870203386 (patch)
treeef26822511b5dfe4eba238e4a9f0665bc99201e7 /target/linux/generic/patches-3.9/430-mtd_myloader_partition_parser.patch
parenteea3a89a6a158dda4751802d952ddc07408c1b0a (diff)
downloadmaster-31e0f0ae-54cd991725079fdce550e86f2303ece870203386.tar.gz
master-31e0f0ae-54cd991725079fdce550e86f2303ece870203386.tar.bz2
master-31e0f0ae-54cd991725079fdce550e86f2303ece870203386.zip
kernel: drop 3.9 support
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 42452
Diffstat (limited to 'target/linux/generic/patches-3.9/430-mtd_myloader_partition_parser.patch')
-rw-r--r--target/linux/generic/patches-3.9/430-mtd_myloader_partition_parser.patch35
1 files changed, 0 insertions, 35 deletions
diff --git a/target/linux/generic/patches-3.9/430-mtd_myloader_partition_parser.patch b/target/linux/generic/patches-3.9/430-mtd_myloader_partition_parser.patch
deleted file mode 100644
index 0f3379897d..0000000000
--- a/target/linux/generic/patches-3.9/430-mtd_myloader_partition_parser.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- a/drivers/mtd/Kconfig
-+++ b/drivers/mtd/Kconfig
-@@ -163,6 +163,22 @@ config MTD_BCM47XX_PARTS
- This provides partitions parser for devices based on BCM47xx
- boards.
-
-+config MTD_MYLOADER_PARTS
-+ tristate "MyLoader partition parsing"
-+ depends on ADM5120 || ATHEROS_AR231X || ATHEROS_AR71XX || ATH79
-+ ---help---
-+ MyLoader is a bootloader which allows the user to define partitions
-+ in flash devices, by putting a table in the second erase block
-+ on the device, similar to a partition table. This table gives the
-+ offsets and lengths of the user defined partitions.
-+
-+ If you need code which can detect and parse these tables, and
-+ register MTD 'partitions' corresponding to each image detected,
-+ enable this option.
-+
-+ You will still need the parsing functions to be called by the driver
-+ for your particular device. It won't happen automatically.
-+
- comment "User Modules And Translation Layers"
-
- config MTD_CHAR
---- a/drivers/mtd/Makefile
-+++ b/drivers/mtd/Makefile
-@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
- obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
- obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
- obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
-+obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
-
- # 'Users' - code which presents functionality to userspace.
- obj-$(CONFIG_MTD_CHAR) += mtdchar.o