summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.8/832-ledtrig_usbdev.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-19 11:58:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-19 11:58:59 +0000
commit32a6800a4198273386510b991fee7ab3d90a4afd (patch)
treef742bdd68f5c3a7d0a2ad46dae1e921a465bbc39 /target/linux/generic/patches-3.8/832-ledtrig_usbdev.patch
parent3600b84cbd9696496d3a7862f003d839c177d088 (diff)
downloadmaster-31e0f0ae-32a6800a4198273386510b991fee7ab3d90a4afd.tar.gz
master-31e0f0ae-32a6800a4198273386510b991fee7ab3d90a4afd.tar.bz2
master-31e0f0ae-32a6800a4198273386510b991fee7ab3d90a4afd.zip
kernel: remove linux 3.8 support
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 44890
Diffstat (limited to 'target/linux/generic/patches-3.8/832-ledtrig_usbdev.patch')
-rw-r--r--target/linux/generic/patches-3.8/832-ledtrig_usbdev.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/target/linux/generic/patches-3.8/832-ledtrig_usbdev.patch b/target/linux/generic/patches-3.8/832-ledtrig_usbdev.patch
deleted file mode 100644
index 5b07f17a90..0000000000
--- a/target/linux/generic/patches-3.8/832-ledtrig_usbdev.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/drivers/leds/Kconfig
-+++ b/drivers/leds/Kconfig
-@@ -572,4 +572,11 @@ config LEDS_TRIGGER_NETDEV
- This allows LEDs to be controlled by network device activity.
- If unsure, say Y.
-
-+config LEDS_TRIGGER_USBDEV
-+ tristate "LED USB device Trigger"
-+ depends on USB && LEDS_TRIGGERS
-+ help
-+ This allows LEDs to be controlled by the presence/activity of
-+ an USB device. If unsure, say N.
-+
- endif # NEW_LEDS
---- a/drivers/leds/Makefile
-+++ b/drivers/leds/Makefile
-@@ -67,3 +67,4 @@ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) +=
- obj-$(CONFIG_LEDS_TRIGGER_TRANSIENT) += ledtrig-transient.o
- obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
- obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
-+obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
---- a/drivers/leds/ledtrig-usbdev.c
-+++ b/drivers/leds/ledtrig-usbdev.c
-@@ -24,7 +24,6 @@
- #include <linux/list.h>
- #include <linux/spinlock.h>
- #include <linux/device.h>
--#include <linux/sysdev.h>
- #include <linux/timer.h>
- #include <linux/ctype.h>
- #include <linux/slab.h>