summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.8/729-phy-tantos.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-01-08 22:19:31 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-01-08 22:19:31 +0000
commit8dbed04ec9cad7771590af557b9edfe8e04bca8c (patch)
tree412beb5055a726a8f371c35580bdc85300e4e2f7 /target/linux/generic/patches-3.8/729-phy-tantos.patch
parentc38cb63808ff1a395dd0384af23773b044adf9cb (diff)
downloadmaster-31e0f0ae-8dbed04ec9cad7771590af557b9edfe8e04bca8c.tar.gz
master-31e0f0ae-8dbed04ec9cad7771590af557b9edfe8e04bca8c.tar.bz2
master-31e0f0ae-8dbed04ec9cad7771590af557b9edfe8e04bca8c.zip
kernel: add support for 3.8-rc2
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 35055
Diffstat (limited to 'target/linux/generic/patches-3.8/729-phy-tantos.patch')
-rw-r--r--target/linux/generic/patches-3.8/729-phy-tantos.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.8/729-phy-tantos.patch b/target/linux/generic/patches-3.8/729-phy-tantos.patch
new file mode 100644
index 0000000000..bc8be2b0dc
--- /dev/null
+++ b/target/linux/generic/patches-3.8/729-phy-tantos.patch
@@ -0,0 +1,21 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -257,3 +257,8 @@ endif # PHYLIB
+ config MICREL_KS8995MA
+ tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
+ depends on SPI
++
++config PSB6970_PHY
++ tristate "Lantiq XWAY Tantos (PSB6970) Ethernet switch"
++ select SWCONFIG
++ select ETHERNET_PACKET_MANGLE
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -30,6 +30,7 @@ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+ obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_MICREL_PHY) += micrel.o
++obj-$(CONFIG_PSB6970_PHY) += psb6970.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o