summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.7/940-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2012-11-18 18:52:38 +0000
committerImre Kaloz <kaloz@openwrt.org>2012-11-18 18:52:38 +0000
commit935ca3f3eb7435b50b91bc2ed341a4bbd6e759b0 (patch)
tree48e34d859046c692a221dddd165db5abc37feb90 /target/linux/generic/patches-3.7/940-ocf_kbuild_integration.patch
parentd0226aff1d62d39530819938ac116ee3cbb93efa (diff)
downloadmaster-31e0f0ae-935ca3f3eb7435b50b91bc2ed341a4bbd6e759b0.tar.gz
master-31e0f0ae-935ca3f3eb7435b50b91bc2ed341a4bbd6e759b0.tar.bz2
master-31e0f0ae-935ca3f3eb7435b50b91bc2ed341a4bbd6e759b0.zip
add 3.7-rc6 support (patch 820 still has to be fixed)
SVN-Revision: 34247
Diffstat (limited to 'target/linux/generic/patches-3.7/940-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-3.7/940-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.7/940-ocf_kbuild_integration.patch b/target/linux/generic/patches-3.7/940-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..915bdd0228
--- /dev/null
+++ b/target/linux/generic/patches-3.7/940-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -1226,3 +1226,6 @@ source "drivers/crypto/Kconfig"
+ source crypto/asymmetric_keys/Kconfig
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -93,6 +93,8 @@ obj-$(CONFIG_CRYPTO_USER_API) += af_alg.
+ obj-$(CONFIG_CRYPTO_USER_API_HASH) += algif_hash.o
+ obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) += algif_skcipher.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #