summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.7/901-debloat_sock_diag.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-12-17 15:11:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-12-17 15:11:39 +0000
commit2bda7a5b4106e4e8eb0e073bd4627db14ca81008 (patch)
treeae3d89162607c568745a7c6a3de1a8376e354c4d /target/linux/generic/patches-3.7/901-debloat_sock_diag.patch
parentf403e2dcca7b2ee86ef84c3bf673e521495b1534 (diff)
downloadmaster-31e0f0ae-2bda7a5b4106e4e8eb0e073bd4627db14ca81008.tar.gz
master-31e0f0ae-2bda7a5b4106e4e8eb0e073bd4627db14ca81008.tar.bz2
master-31e0f0ae-2bda7a5b4106e4e8eb0e073bd4627db14ca81008.zip
kernel: add some debloat patches, strip down procfs and make O_DIRECT support optional, saves ~15K after lzma on MIPS
SVN-Revision: 34737
Diffstat (limited to 'target/linux/generic/patches-3.7/901-debloat_sock_diag.patch')
-rw-r--r--target/linux/generic/patches-3.7/901-debloat_sock_diag.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.7/901-debloat_sock_diag.patch b/target/linux/generic/patches-3.7/901-debloat_sock_diag.patch
new file mode 100644
index 0000000000..119760648d
--- /dev/null
+++ b/target/linux/generic/patches-3.7/901-debloat_sock_diag.patch
@@ -0,0 +1,46 @@
+--- a/net/Kconfig
++++ b/net/Kconfig
+@@ -87,6 +87,9 @@ source "net/netlabel/Kconfig"
+
+ endif # if INET
+
++config SOCK_DIAG
++ bool
++
+ config NETWORK_SECMARK
+ bool "Security Marking"
+ help
+--- a/net/core/Makefile
++++ b/net/core/Makefile
+@@ -8,9 +8,9 @@ obj-y := sock.o request_sock.o skbuff.o
+ obj-$(CONFIG_SYSCTL) += sysctl_net_core.o
+
+ obj-y += dev.o ethtool.o dev_addr_lists.o dst.o netevent.o \
+- neighbour.o rtnetlink.o utils.o link_watch.o filter.o \
+- sock_diag.o
++ neighbour.o rtnetlink.o utils.o link_watch.o filter.o
+
++obj-$(CONFIG_SOCK_DIAG) += sock_diag.o
+ obj-$(CONFIG_XFRM) += flow.o
+ obj-y += net-sysfs.o
+ obj-$(CONFIG_NET_PKTGEN) += pktgen.o
+--- a/net/ipv4/Kconfig
++++ b/net/ipv4/Kconfig
+@@ -404,6 +404,7 @@ config INET_LRO
+
+ config INET_DIAG
+ tristate "INET: socket monitoring interface"
++ select SOCK_DIAG
+ default y
+ ---help---
+ Support for INET (TCP, DCCP, etc) socket monitoring interface used by
+--- a/net/unix/Kconfig
++++ b/net/unix/Kconfig
+@@ -22,6 +22,7 @@ config UNIX
+ config UNIX_DIAG
+ tristate "UNIX: socket monitoring interface"
+ depends on UNIX
++ select SOCK_DIAG
+ default n
+ ---help---
+ Support for UNIX socket monitoring interface used by the ss tool.