summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.7/720-phy_adm6996.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2012-11-18 18:52:38 +0000
committerImre Kaloz <kaloz@openwrt.org>2012-11-18 18:52:38 +0000
commit935ca3f3eb7435b50b91bc2ed341a4bbd6e759b0 (patch)
tree48e34d859046c692a221dddd165db5abc37feb90 /target/linux/generic/patches-3.7/720-phy_adm6996.patch
parentd0226aff1d62d39530819938ac116ee3cbb93efa (diff)
downloadmaster-31e0f0ae-935ca3f3eb7435b50b91bc2ed341a4bbd6e759b0.tar.gz
master-31e0f0ae-935ca3f3eb7435b50b91bc2ed341a4bbd6e759b0.tar.bz2
master-31e0f0ae-935ca3f3eb7435b50b91bc2ed341a4bbd6e759b0.zip
add 3.7-rc6 support (patch 820 still has to be fixed)
SVN-Revision: 34247
Diffstat (limited to 'target/linux/generic/patches-3.7/720-phy_adm6996.patch')
-rw-r--r--target/linux/generic/patches-3.7/720-phy_adm6996.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.7/720-phy_adm6996.patch b/target/linux/generic/patches-3.7/720-phy_adm6996.patch
new file mode 100644
index 0000000000..04d49e9cca
--- /dev/null
+++ b/target/linux/generic/patches-3.7/720-phy_adm6996.patch
@@ -0,0 +1,26 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -121,6 +121,13 @@ config MICREL_PHY
+ ---help---
+ Supports the KSZ9021, VSC8201, KS8001 PHYs.
+
++config ADM6996_PHY
++ tristate "Driver for ADM6996 switches"
++ select SWCONFIG
++ ---help---
++ Currently supports the ADM6996FC and ADM6996M switches.
++ Support for FC is very limited.
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -17,6 +17,7 @@ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
+ obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
+ obj-$(CONFIG_BCM87XX_PHY) += bcm87xx.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
++obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o