summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.6
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-01-23 10:12:33 +0000
committerJonas Gorski <jogo@openwrt.org>2013-01-23 10:12:33 +0000
commitbb0118c66fbf7cefe47b5964188ef5cc53a530f6 (patch)
tree3a61abd3b31fc063bc3b87134278a1a3b5b325fa /target/linux/generic/patches-3.6
parent3e998d9cf9b157e0fc31e4b6dcc1345db7b4743c (diff)
downloadmaster-31e0f0ae-bb0118c66fbf7cefe47b5964188ef5cc53a530f6.tar.gz
master-31e0f0ae-bb0118c66fbf7cefe47b5964188ef5cc53a530f6.tar.bz2
master-31e0f0ae-bb0118c66fbf7cefe47b5964188ef5cc53a530f6.zip
generic: add b53 swconfig switch driver
Add swconfig switch driver for Broadcom BCM53XX switch chips. Supports switches connected through MDIO, SPI or memory mapped registers, and supports BCM5325, BCM539x, BCM531x5 and the BCM63XX internal switch chips. Tested are BCM5325 trough MDIO, BCM53115 through SPI, and BCM6328. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 35305
Diffstat (limited to 'target/linux/generic/patches-3.6')
-rw-r--r--target/linux/generic/patches-3.6/730-phy_b53.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.6/730-phy_b53.patch b/target/linux/generic/patches-3.6/730-phy_b53.patch
new file mode 100644
index 0000000000..3922d474dd
--- /dev/null
+++ b/target/linux/generic/patches-3.6/730-phy_b53.patch
@@ -0,0 +1,21 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -234,6 +234,8 @@ config RTL8367B_PHY
+
+ endif # RTL8366_SMI
+
++source "drivers/net/phy/b53/Kconfig"
++
+ endif # PHYLIB
+
+ config MICREL_KS8995MA
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -31,6 +31,7 @@ obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_MICREL_PHY) += micrel.o
+ obj-$(CONFIG_PSB6970_PHY) += psb6970.o
++obj-$(CONFIG_B53) += b53/
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o