summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.6/830-ledtrig_morse.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2012-10-23 12:21:34 +0000
committerImre Kaloz <kaloz@openwrt.org>2012-10-23 12:21:34 +0000
commit949b46d13d1e21b596f505a2e69956565e365d77 (patch)
tree4b51f4852224df7cc2d056071ee51bfcb9c5b7f4 /target/linux/generic/patches-3.6/830-ledtrig_morse.patch
parent0d2cf5f9e363c8e41b32921b0ab2aa3d4621dfd5 (diff)
downloadmaster-31e0f0ae-949b46d13d1e21b596f505a2e69956565e365d77.tar.gz
master-31e0f0ae-949b46d13d1e21b596f505a2e69956565e365d77.tar.bz2
master-31e0f0ae-949b46d13d1e21b596f505a2e69956565e365d77.zip
linux 3.6 support (work in progress)
SVN-Revision: 33897
Diffstat (limited to 'target/linux/generic/patches-3.6/830-ledtrig_morse.patch')
-rw-r--r--target/linux/generic/patches-3.6/830-ledtrig_morse.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.6/830-ledtrig_morse.patch b/target/linux/generic/patches-3.6/830-ledtrig_morse.patch
new file mode 100644
index 0000000000..3283807f2b
--- /dev/null
+++ b/target/linux/generic/patches-3.6/830-ledtrig_morse.patch
@@ -0,0 +1,28 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -480,4 +480,8 @@ config LEDS_TRIGGER_DEFAULT_ON
+ comment "iptables trigger is under Netfilter config (LED target)"
+ depends on LEDS_TRIGGERS
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -57,3 +57,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
+ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
+ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+--- a/drivers/leds/ledtrig-morse.c
++++ b/drivers/leds/ledtrig-morse.c
+@@ -26,7 +26,6 @@
+ #include <linux/list.h>
+ #include <linux/spinlock.h>
+ #include <linux/device.h>
+-#include <linux/sysdev.h>
+ #include <linux/timer.h>
+ #include <linux/ctype.h>
+ #include <linux/leds.h>