summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.6/430-mtd_myloader_partition_parser.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2012-10-23 12:21:34 +0000
committerImre Kaloz <kaloz@openwrt.org>2012-10-23 12:21:34 +0000
commit949b46d13d1e21b596f505a2e69956565e365d77 (patch)
tree4b51f4852224df7cc2d056071ee51bfcb9c5b7f4 /target/linux/generic/patches-3.6/430-mtd_myloader_partition_parser.patch
parent0d2cf5f9e363c8e41b32921b0ab2aa3d4621dfd5 (diff)
downloadmaster-31e0f0ae-949b46d13d1e21b596f505a2e69956565e365d77.tar.gz
master-31e0f0ae-949b46d13d1e21b596f505a2e69956565e365d77.tar.bz2
master-31e0f0ae-949b46d13d1e21b596f505a2e69956565e365d77.zip
linux 3.6 support (work in progress)
SVN-Revision: 33897
Diffstat (limited to 'target/linux/generic/patches-3.6/430-mtd_myloader_partition_parser.patch')
-rw-r--r--target/linux/generic/patches-3.6/430-mtd_myloader_partition_parser.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.6/430-mtd_myloader_partition_parser.patch b/target/linux/generic/patches-3.6/430-mtd_myloader_partition_parser.patch
new file mode 100644
index 0000000000..d60126dcdf
--- /dev/null
+++ b/target/linux/generic/patches-3.6/430-mtd_myloader_partition_parser.patch
@@ -0,0 +1,35 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -156,6 +156,22 @@ config MTD_BCM63XX_PARTS
+ This provides partions parsing for BCM63xx devices with CFE
+ bootloaders.
+
++config MTD_MYLOADER_PARTS
++ tristate "MyLoader partition parsing"
++ depends on ADM5120 || ATHEROS_AR231X || ATHEROS_AR71XX || ATH79
++ ---help---
++ MyLoader is a bootloader which allows the user to define partitions
++ in flash devices, by putting a table in the second erase block
++ on the device, similar to a partition table. This table gives the
++ offsets and lengths of the user defined partitions.
++
++ If you need code which can detect and parse these tables, and
++ register MTD 'partitions' corresponding to each image detected,
++ enable this option.
++
++ You will still need the parsing functions to be called by the driver
++ for your particular device. It won't happen automatically.
++
+ comment "User Modules And Translation Layers"
+
+ config MTD_CHAR
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdli
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+ obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
+ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
++obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
+
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_CHAR) += mtdchar.o