summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.3
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-27 17:09:43 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-27 17:09:43 +0000
commit9217115687d4abf15e898b185da07cac883f5c82 (patch)
tree4949fc90d226600260d3118cc538066268df7815 /target/linux/generic/patches-3.3
parent466ef3017307579de1bb529097427a009d562623 (diff)
downloadmaster-31e0f0ae-9217115687d4abf15e898b185da07cac883f5c82.tar.gz
master-31e0f0ae-9217115687d4abf15e898b185da07cac883f5c82.tar.bz2
master-31e0f0ae-9217115687d4abf15e898b185da07cac883f5c82.zip
generic: rtl8366_smi: rename debugfs Kconfig symbol
SVN-Revision: 31915
Diffstat (limited to 'target/linux/generic/patches-3.3')
-rw-r--r--target/linux/generic/patches-3.3/726-phy_rtl8366.patch13
-rw-r--r--target/linux/generic/patches-3.3/727-phy-rtl8367.patch8
2 files changed, 10 insertions, 11 deletions
diff --git a/target/linux/generic/patches-3.3/726-phy_rtl8366.patch b/target/linux/generic/patches-3.3/726-phy_rtl8366.patch
index fee8b78860..d258e4b564 100644
--- a/target/linux/generic/patches-3.3/726-phy_rtl8366.patch
+++ b/target/linux/generic/patches-3.3/726-phy_rtl8366.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -168,6 +168,31 @@ config MDIO_OCTEON
+@@ -168,6 +168,30 @@ config MDIO_OCTEON
If in doubt, say Y.
@@ -13,6 +13,11 @@
+
+if RTL8366_SMI
+
++config RTL8366_SMI_DEBUG_FS
++ bool "RTL8366 SMI interface debugfs support"
++ depends on DEBUG_FS
++ default n
++
+config RTL8366S_PHY
+ tristate "Driver for the Realtek RTL8366S switch"
+ select SWCONFIG
@@ -21,12 +26,6 @@
+ tristate "Driver for the Realtek RTL8366RB switch"
+ select SWCONFIG
+
-+config RTL8366S_PHY_DEBUG_FS
-+ bool "RTL8366 switch driver DEBUG_FS support"
-+ depends on RTL8366S_PHY || RTL8366RB_PHY
-+ depends on DEBUG_FS
-+ default n
-+
+endif # RTL8366_SMI
+
endif # PHYLIB
diff --git a/target/linux/generic/patches-3.3/727-phy-rtl8367.patch b/target/linux/generic/patches-3.3/727-phy-rtl8367.patch
index 3af6101910..a24f497c9b 100644
--- a/target/linux/generic/patches-3.3/727-phy-rtl8367.patch
+++ b/target/linux/generic/patches-3.3/727-phy-rtl8367.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -185,6 +185,10 @@ config RTL8366RB_PHY
+@@ -190,6 +190,10 @@ config RTL8366RB_PHY
tristate "Driver for the Realtek RTL8366RB switch"
select SWCONFIG
@@ -8,9 +8,9 @@
+ tristate "Driver for the Realtek RTL8367R/M switches"
+ select SWCONFIG
+
- config RTL8366S_PHY_DEBUG_FS
- bool "RTL8366 switch driver DEBUG_FS support"
- depends on RTL8366S_PHY || RTL8366RB_PHY
+ endif # RTL8366_SMI
+
+ endif # PHYLIB
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
@@ -25,6 +25,7 @@ obj-$(CONFIG_RTL8306_PHY) += rtl8306.o