summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.3
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-01-05 13:03:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-01-05 13:03:07 +0000
commit1cbf0fbcb42843eeda5e03fe34f9cf7c1db99f49 (patch)
tree3453ca0a098d90e16923e97d0eeca0446d6fb4d8 /target/linux/generic/patches-3.3
parentcc02d4c72dbe7b4ef143e390776792260503bd53 (diff)
downloadmaster-31e0f0ae-1cbf0fbcb42843eeda5e03fe34f9cf7c1db99f49.tar.gz
master-31e0f0ae-1cbf0fbcb42843eeda5e03fe34f9cf7c1db99f49.tar.bz2
master-31e0f0ae-1cbf0fbcb42843eeda5e03fe34f9cf7c1db99f49.zip
ar8216: factor out AR8327/AR8337-specific driver code into ar8327.c
Move all AR8327/AR8337-specific driver code into a separate source file ar8327.c and adjust patches so that ar8327.c is compiled if CONFIG_AR8216_PHY is set. Signed-off-by: Heiner Kallweit <hkallweit1@gmail.com> SVN-Revision: 43845
Diffstat (limited to 'target/linux/generic/patches-3.3')
-rw-r--r--target/linux/generic/patches-3.3/724-phy_ar8216.patch2
-rw-r--r--target/linux/generic/patches-3.3/725-phy_rtl8306.patch2
-rw-r--r--target/linux/generic/patches-3.3/726-phy_rtl8366.patch2
3 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/generic/patches-3.3/724-phy_ar8216.patch b/target/linux/generic/patches-3.3/724-phy_ar8216.patch
index eed6e2b92a..6ed7392a85 100644
--- a/target/linux/generic/patches-3.3/724-phy_ar8216.patch
+++ b/target/linux/generic/patches-3.3/724-phy_ar8216.patch
@@ -18,7 +18,7 @@
obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
-+obj-$(CONFIG_AR8216_PHY) += ar8216.o
++obj-$(CONFIG_AR8216_PHY) += ar8216.o ar8327.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
obj-$(CONFIG_FIXED_PHY) += fixed.o
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
diff --git a/target/linux/generic/patches-3.3/725-phy_rtl8306.patch b/target/linux/generic/patches-3.3/725-phy_rtl8306.patch
index db0ee6582e..8bde5f2eb1 100644
--- a/target/linux/generic/patches-3.3/725-phy_rtl8306.patch
+++ b/target/linux/generic/patches-3.3/725-phy_rtl8306.patch
@@ -16,7 +16,7 @@
@@ -21,6 +21,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
- obj-$(CONFIG_AR8216_PHY) += ar8216.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o ar8327.o
+obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
obj-$(CONFIG_FIXED_PHY) += fixed.o
diff --git a/target/linux/generic/patches-3.3/726-phy_rtl8366.patch b/target/linux/generic/patches-3.3/726-phy_rtl8366.patch
index d258e4b564..fd952d1fab 100644
--- a/target/linux/generic/patches-3.3/726-phy_rtl8366.patch
+++ b/target/linux/generic/patches-3.3/726-phy_rtl8366.patch
@@ -35,7 +35,7 @@
+++ b/drivers/net/phy/Makefile
@@ -22,6 +22,9 @@ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
- obj-$(CONFIG_AR8216_PHY) += ar8216.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o ar8327.o
obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
+obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o