summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.3/940-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2012-02-02 08:23:54 +0000
committerJonas Gorski <jogo@openwrt.org>2012-02-02 08:23:54 +0000
commiteca9950f63ec4491a7bd6138174ac08595184e1b (patch)
treea21d36b4e93a079ce234258a3a82b97dd82c10bf /target/linux/generic/patches-3.3/940-ocf_kbuild_integration.patch
parentc336de3d85efb1a1150825870b7cbff4f7a65366 (diff)
downloadmaster-31e0f0ae-eca9950f63ec4491a7bd6138174ac08595184e1b.tar.gz
master-31e0f0ae-eca9950f63ec4491a7bd6138174ac08595184e1b.tar.bz2
master-31e0f0ae-eca9950f63ec4491a7bd6138174ac08595184e1b.zip
kernel: add preliminary support for linux 3.3
Based on 3.3-rc2 SVN-Revision: 29986
Diffstat (limited to 'target/linux/generic/patches-3.3/940-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-3.3/940-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.3/940-ocf_kbuild_integration.patch b/target/linux/generic/patches-3.3/940-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..55a2bed030
--- /dev/null
+++ b/target/linux/generic/patches-3.3/940-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -961,3 +961,6 @@ config CRYPTO_USER_API_SKCIPHER
+ source "drivers/crypto/Kconfig"
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -91,6 +91,8 @@ obj-$(CONFIG_CRYPTO_USER_API) += af_alg.
+ obj-$(CONFIG_CRYPTO_USER_API_HASH) += algif_hash.o
+ obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) += algif_skcipher.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #