summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.2/940-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2012-01-13 14:55:07 +0000
committerJonas Gorski <jogo@openwrt.org>2012-01-13 14:55:07 +0000
commit1bc0abb058e09fd7214507dd4a095658a4b8d122 (patch)
tree82c35f5f43253e1a2ff9c2ff1318fac1c86e57df /target/linux/generic/patches-3.2/940-ocf_kbuild_integration.patch
parent50d4c0e31a6706f28b3c69cd24bcf0c205223e16 (diff)
downloadmaster-31e0f0ae-1bc0abb058e09fd7214507dd4a095658a4b8d122.tar.gz
master-31e0f0ae-1bc0abb058e09fd7214507dd4a095658a4b8d122.tar.bz2
master-31e0f0ae-1bc0abb058e09fd7214507dd4a095658a4b8d122.zip
kernel: add support for linux 3.2.1
SVN-Revision: 29730
Diffstat (limited to 'target/linux/generic/patches-3.2/940-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-3.2/940-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.2/940-ocf_kbuild_integration.patch b/target/linux/generic/patches-3.2/940-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..f22bd4ccd4
--- /dev/null
+++ b/target/linux/generic/patches-3.2/940-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -923,3 +923,6 @@ config CRYPTO_USER_API_SKCIPHER
+ source "drivers/crypto/Kconfig"
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -91,6 +91,8 @@ obj-$(CONFIG_CRYPTO_USER_API) += af_alg.
+ obj-$(CONFIG_CRYPTO_USER_API_HASH) += algif_hash.o
+ obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) += algif_skcipher.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #