summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.2/727-phy-rtl8367.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2012-01-13 14:55:07 +0000
committerJonas Gorski <jogo@openwrt.org>2012-01-13 14:55:07 +0000
commit1bc0abb058e09fd7214507dd4a095658a4b8d122 (patch)
tree82c35f5f43253e1a2ff9c2ff1318fac1c86e57df /target/linux/generic/patches-3.2/727-phy-rtl8367.patch
parent50d4c0e31a6706f28b3c69cd24bcf0c205223e16 (diff)
downloadmaster-31e0f0ae-1bc0abb058e09fd7214507dd4a095658a4b8d122.tar.gz
master-31e0f0ae-1bc0abb058e09fd7214507dd4a095658a4b8d122.tar.bz2
master-31e0f0ae-1bc0abb058e09fd7214507dd4a095658a4b8d122.zip
kernel: add support for linux 3.2.1
SVN-Revision: 29730
Diffstat (limited to 'target/linux/generic/patches-3.2/727-phy-rtl8367.patch')
-rw-r--r--target/linux/generic/patches-3.2/727-phy-rtl8367.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.2/727-phy-rtl8367.patch b/target/linux/generic/patches-3.2/727-phy-rtl8367.patch
new file mode 100644
index 0000000000..820bda0cdb
--- /dev/null
+++ b/target/linux/generic/patches-3.2/727-phy-rtl8367.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -179,6 +179,10 @@ config RTL8366RB_PHY
+ tristate "Driver for the Realtek RTL8366RB switch"
+ select SWCONFIG
+
++config RTL8367_PHY
++ tristate "Driver for the Realtek RTL8367R/M switches"
++ select SWCONFIG
++
+ config RTL8366S_PHY_DEBUG_FS
+ bool "RTL8366 switch driver DEBUG_FS support"
+ depends on RTL8366S_PHY || RTL8366RB_PHY
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -23,6 +23,7 @@ obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+ obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
+ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
++obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o