summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.19/730-phy_b53.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-01-25 15:20:39 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-01-25 15:20:39 +0000
commitd26694243af236fed09a4b38f3cc68e40ad063b5 (patch)
treedf356ae59718ae0996986ccb61155243098dbc3f /target/linux/generic/patches-3.19/730-phy_b53.patch
parenta46bb6ec6a0ed6eb56dc2f4551a57e63a7292753 (diff)
downloadmaster-31e0f0ae-d26694243af236fed09a4b38f3cc68e40ad063b5.tar.gz
master-31e0f0ae-d26694243af236fed09a4b38f3cc68e40ad063b5.tar.bz2
master-31e0f0ae-d26694243af236fed09a4b38f3cc68e40ad063b5.zip
generic: add preliminary 3.19 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 44126
Diffstat (limited to 'target/linux/generic/patches-3.19/730-phy_b53.patch')
-rw-r--r--target/linux/generic/patches-3.19/730-phy_b53.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.19/730-phy_b53.patch b/target/linux/generic/patches-3.19/730-phy_b53.patch
new file mode 100644
index 0000000000..7e3a117b26
--- /dev/null
+++ b/target/linux/generic/patches-3.19/730-phy_b53.patch
@@ -0,0 +1,21 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -282,6 +282,8 @@ config RTL8367B_PHY
+
+ endif # RTL8366_SMI
+
++source "drivers/net/phy/b53/Kconfig"
++
+ endif # PHYLIB
+
+ config MICREL_KS8995MA
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -31,6 +31,7 @@ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+ obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_PSB6970_PHY) += psb6970.o
++obj-$(CONFIG_B53) += b53/
+ obj-$(CONFIG_FIXED_PHY) += fixed_phy.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o