summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.19/430-mtd-add-myloader-partition-parser.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-01-25 15:20:39 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-01-25 15:20:39 +0000
commitd26694243af236fed09a4b38f3cc68e40ad063b5 (patch)
treedf356ae59718ae0996986ccb61155243098dbc3f /target/linux/generic/patches-3.19/430-mtd-add-myloader-partition-parser.patch
parenta46bb6ec6a0ed6eb56dc2f4551a57e63a7292753 (diff)
downloadmaster-31e0f0ae-d26694243af236fed09a4b38f3cc68e40ad063b5.tar.gz
master-31e0f0ae-d26694243af236fed09a4b38f3cc68e40ad063b5.tar.bz2
master-31e0f0ae-d26694243af236fed09a4b38f3cc68e40ad063b5.zip
generic: add preliminary 3.19 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 44126
Diffstat (limited to 'target/linux/generic/patches-3.19/430-mtd-add-myloader-partition-parser.patch')
-rw-r--r--target/linux/generic/patches-3.19/430-mtd-add-myloader-partition-parser.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.19/430-mtd-add-myloader-partition-parser.patch b/target/linux/generic/patches-3.19/430-mtd-add-myloader-partition-parser.patch
new file mode 100644
index 0000000000..45af25dd61
--- /dev/null
+++ b/target/linux/generic/patches-3.19/430-mtd-add-myloader-partition-parser.patch
@@ -0,0 +1,35 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -184,6 +184,22 @@ config MTD_BCM47XX_PARTS
+ This provides partitions parser for devices based on BCM47xx
+ boards.
+
++config MTD_MYLOADER_PARTS
++ tristate "MyLoader partition parsing"
++ depends on ADM5120 || ATHEROS_AR231X || ATHEROS_AR71XX || ATH79
++ ---help---
++ MyLoader is a bootloader which allows the user to define partitions
++ in flash devices, by putting a table in the second erase block
++ on the device, similar to a partition table. This table gives the
++ offsets and lengths of the user defined partitions.
++
++ If you need code which can detect and parse these tables, and
++ register MTD 'partitions' corresponding to each image detected,
++ enable this option.
++
++ You will still need the parsing functions to be called by the driver
++ for your particular device. It won't happen automatically.
++
+ comment "User Modules And Translation Layers"
+
+ #
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -15,6 +15,7 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+ obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
+ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
+ obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
++obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
+
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_BLKDEVS) += mtd_blkdevs.o