summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.18
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-12-01 21:30:35 +0000
committerJohn Crispin <john@openwrt.org>2014-12-01 21:30:35 +0000
commit9b5f5839066ff8958c0bb468623db3a82a9806be (patch)
treeb10af3ab00c7088b3e08a1d3501d73f2af5db2cb /target/linux/generic/patches-3.18
parentb8dd6bb1898b79adbcf386fed86caad276246f78 (diff)
downloadmaster-31e0f0ae-9b5f5839066ff8958c0bb468623db3a82a9806be.tar.gz
master-31e0f0ae-9b5f5839066ff8958c0bb468623db3a82a9806be.tar.bz2
master-31e0f0ae-9b5f5839066ff8958c0bb468623db3a82a9806be.zip
kernel: add driver for Marvell 88E6171 switch
This is a swconfig driver for the Marvell 88E6171 switch, which is a 7-port GigE switch with two CPU ports and 64 802.1q VLANs. Signed-off-by: Claudio Leite <leitec@staticky.com> SVN-Revision: 43486
Diffstat (limited to 'target/linux/generic/patches-3.18')
-rw-r--r--target/linux/generic/patches-3.18/733-phy_mvsw6171.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.18/733-phy_mvsw6171.patch b/target/linux/generic/patches-3.18/733-phy_mvsw6171.patch
new file mode 100644
index 0000000000..291164791f
--- /dev/null
+++ b/target/linux/generic/patches-3.18/733-phy_mvsw6171.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -143,6 +143,10 @@ config MVSWITCH_PHY
+ tristate "Driver for Marvell 88E6060 switches"
+ select ETHERNET_PACKET_MANGLE
+
++config MVSW6171_PHY
++ tristate "Driver for Marvell 88E6171 switches"
++ select SWCONFIG
++
+ config IP17XX_PHY
+ tristate "Driver for IC+ IP17xx switches"
+ select SWCONFIG
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -20,6 +20,7 @@ obj-$(CONFIG_BCM87XX_PHY) += bcm87xx.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
++obj-$(CONFIG_MVSW6171_PHY) += mvsw6171.o
+ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o