summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.18
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-01-02 21:52:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-01-02 21:52:35 +0000
commit4153c0adff074167f1eb934235129471d2c04199 (patch)
tree9e90c8956937880242065443a6da0d8a0ed22aff /target/linux/generic/patches-3.18
parent6bfd210ade2a5d35950f56aeeac2d0ee1b8499e0 (diff)
downloadmaster-31e0f0ae-4153c0adff074167f1eb934235129471d2c04199.tar.gz
master-31e0f0ae-4153c0adff074167f1eb934235129471d2c04199.tar.bz2
master-31e0f0ae-4153c0adff074167f1eb934235129471d2c04199.zip
kernel: move mtdsplit files to drivers/mtd/mtdsplit/ to simplify maintenance, unify patches across kernel versions
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43805
Diffstat (limited to 'target/linux/generic/patches-3.18')
-rw-r--r--target/linux/generic/patches-3.18/400-mtd-add-rootfs-split-support.patch2
-rw-r--r--target/linux/generic/patches-3.18/403-mtd-hook-mtdsplit-to-Kbuild.patch9
-rw-r--r--target/linux/generic/patches-3.18/404-mtd-add-more-helper-functions.patch (renamed from target/linux/generic/patches-3.18/405-mtd-add-more-helper-functions.patch)0
-rw-r--r--target/linux/generic/patches-3.18/405-mtd-old-firmware-uimage-splitter.patch (renamed from target/linux/generic/patches-3.18/407-mtd-old-firmware-uimage-splitter.patch)6
-rw-r--r--target/linux/generic/patches-3.18/406-mtd-hook-mtdsplit-into-Kbuild.patch24
-rw-r--r--target/linux/generic/patches-3.18/406-mtd-old-rootfs-squashfs-splitter.patch (renamed from target/linux/generic/patches-3.18/408-mtd-old-rootfs-squashfs-splitter.patch)2
-rw-r--r--target/linux/generic/patches-3.18/411-mtd-partial_eraseblock_write.patch2
-rw-r--r--target/linux/generic/patches-3.18/430-mtd-add-myloader-partition-parser.patch4
-rw-r--r--target/linux/generic/patches-3.18/431-mtd-bcm47xxpart-support-TRX-data-partition-being-UBI.patch2
-rw-r--r--target/linux/generic/patches-3.18/502-yaffs-3.10-disable-proc-entry.patch2
10 files changed, 13 insertions, 40 deletions
diff --git a/target/linux/generic/patches-3.18/400-mtd-add-rootfs-split-support.patch b/target/linux/generic/patches-3.18/400-mtd-add-rootfs-split-support.patch
index 597adf5445..bf69a3509d 100644
--- a/target/linux/generic/patches-3.18/400-mtd-add-rootfs-split-support.patch
+++ b/target/linux/generic/patches-3.18/400-mtd-add-rootfs-split-support.patch
@@ -34,7 +34,7 @@
#include <linux/err.h>
#include "mtdcore.h"
-+#include "mtdsplit.h"
++#include "mtdsplit/mtdsplit.h"
/* Our partition linked list */
static LIST_HEAD(mtd_partitions);
diff --git a/target/linux/generic/patches-3.18/403-mtd-hook-mtdsplit-to-Kbuild.patch b/target/linux/generic/patches-3.18/403-mtd-hook-mtdsplit-to-Kbuild.patch
index d897034abd..0cf1c38555 100644
--- a/target/linux/generic/patches-3.18/403-mtd-hook-mtdsplit-to-Kbuild.patch
+++ b/target/linux/generic/patches-3.18/403-mtd-hook-mtdsplit-to-Kbuild.patch
@@ -1,13 +1,10 @@
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
-@@ -27,6 +27,11 @@ config MTD_SPLIT_FIRMWARE_NAME
+@@ -27,6 +27,8 @@ config MTD_SPLIT_FIRMWARE_NAME
depends on MTD_SPLIT_FIRMWARE
default "firmware"
-+config MTD_SPLIT
-+ def_bool n
-+ help
-+ Generic MTD split support.
++source "drivers/mtd/mtdsplit/Kconfig"
+
endmenu
@@ -18,7 +15,7 @@
obj-$(CONFIG_MTD) += mtd.o
mtd-y := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
-+mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
++obj-$(CONFIG_MTD_SPLIT) += mtdsplit/
+
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
diff --git a/target/linux/generic/patches-3.18/405-mtd-add-more-helper-functions.patch b/target/linux/generic/patches-3.18/404-mtd-add-more-helper-functions.patch
index d7c38011ec..d7c38011ec 100644
--- a/target/linux/generic/patches-3.18/405-mtd-add-more-helper-functions.patch
+++ b/target/linux/generic/patches-3.18/404-mtd-add-more-helper-functions.patch
diff --git a/target/linux/generic/patches-3.18/407-mtd-old-firmware-uimage-splitter.patch b/target/linux/generic/patches-3.18/405-mtd-old-firmware-uimage-splitter.patch
index 34a4b1aa8c..a19202a870 100644
--- a/target/linux/generic/patches-3.18/407-mtd-old-firmware-uimage-splitter.patch
+++ b/target/linux/generic/patches-3.18/405-mtd-old-firmware-uimage-splitter.patch
@@ -11,10 +11,10 @@
+
source "drivers/mtd/mtdsplit/Kconfig"
- config MTD_SPLIT
+ endmenu
--- a/drivers/mtd/mtdpart.c
+++ b/drivers/mtd/mtdpart.c
-@@ -681,6 +681,37 @@ mtd_pad_erasesize(struct mtd_info *mtd,
+@@ -681,6 +681,37 @@ mtd_pad_erasesize(struct mtd_info *mtd,
return len;
}
@@ -52,7 +52,7 @@
#ifdef CONFIG_MTD_SPLIT_FIRMWARE_NAME
#define SPLIT_FIRMWARE_NAME CONFIG_MTD_SPLIT_FIRMWARE_NAME
#else
-@@ -689,7 +720,14 @@ mtd_pad_erasesize(struct mtd_info *mtd,
+@@ -689,7 +720,14 @@ mtd_pad_erasesize(struct mtd_info *mtd,
static void split_firmware(struct mtd_info *master, struct mtd_part *part)
{
diff --git a/target/linux/generic/patches-3.18/406-mtd-hook-mtdsplit-into-Kbuild.patch b/target/linux/generic/patches-3.18/406-mtd-hook-mtdsplit-into-Kbuild.patch
deleted file mode 100644
index 008714bd15..0000000000
--- a/target/linux/generic/patches-3.18/406-mtd-hook-mtdsplit-into-Kbuild.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/drivers/mtd/Kconfig
-+++ b/drivers/mtd/Kconfig
-@@ -27,6 +27,8 @@ config MTD_SPLIT_FIRMWARE_NAME
- depends on MTD_SPLIT_FIRMWARE
- default "firmware"
-
-+source "drivers/mtd/mtdsplit/Kconfig"
-+
- config MTD_SPLIT
- def_bool n
- help
---- a/drivers/mtd/Makefile
-+++ b/drivers/mtd/Makefile
-@@ -7,6 +7,10 @@ obj-$(CONFIG_MTD) += mtd.o
- mtd-y := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
-
- mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
-+mtd-$(CONFIG_MTD_SPLIT_SEAMA_FW) += mtdsplit_seama.o
-+mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
-+mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
-+mtd-$(CONFIG_MTD_SPLIT_LZMA_FW) += mtdsplit_lzma.o
-
- obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
- obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
diff --git a/target/linux/generic/patches-3.18/408-mtd-old-rootfs-squashfs-splitter.patch b/target/linux/generic/patches-3.18/406-mtd-old-rootfs-squashfs-splitter.patch
index ca81958432..d48a681483 100644
--- a/target/linux/generic/patches-3.18/408-mtd-old-rootfs-squashfs-splitter.patch
+++ b/target/linux/generic/patches-3.18/406-mtd-old-rootfs-squashfs-splitter.patch
@@ -14,7 +14,7 @@
default y
--- a/drivers/mtd/mtdpart.c
+++ b/drivers/mtd/mtdpart.c
-@@ -681,6 +681,47 @@ mtd_pad_erasesize(struct mtd_info *mtd,
+@@ -681,6 +681,47 @@ mtd_pad_erasesize(struct mtd_info *mtd,
return len;
}
diff --git a/target/linux/generic/patches-3.18/411-mtd-partial_eraseblock_write.patch b/target/linux/generic/patches-3.18/411-mtd-partial_eraseblock_write.patch
index 4a17ccd8d6..0bb7be0848 100644
--- a/target/linux/generic/patches-3.18/411-mtd-partial_eraseblock_write.patch
+++ b/target/linux/generic/patches-3.18/411-mtd-partial_eraseblock_write.patch
@@ -2,7 +2,7 @@
+++ b/drivers/mtd/mtdpart.c
@@ -35,6 +35,8 @@
#include "mtdcore.h"
- #include "mtdsplit.h"
+ #include "mtdsplit/mtdsplit.h"
+#define MTD_ERASE_PARTIAL 0x8000 /* partition only covers parts of an erase block */
+
diff --git a/target/linux/generic/patches-3.18/430-mtd-add-myloader-partition-parser.patch b/target/linux/generic/patches-3.18/430-mtd-add-myloader-partition-parser.patch
index ffc9e2199c..45af25dd61 100644
--- a/target/linux/generic/patches-3.18/430-mtd-add-myloader-partition-parser.patch
+++ b/target/linux/generic/patches-3.18/430-mtd-add-myloader-partition-parser.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
-@@ -189,6 +189,22 @@ config MTD_BCM47XX_PARTS
+@@ -184,6 +184,22 @@ config MTD_BCM47XX_PARTS
This provides partitions parser for devices based on BCM47xx
boards.
@@ -25,7 +25,7 @@
#
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
-@@ -19,6 +19,7 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+@@ -15,6 +15,7 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
diff --git a/target/linux/generic/patches-3.18/431-mtd-bcm47xxpart-support-TRX-data-partition-being-UBI.patch b/target/linux/generic/patches-3.18/431-mtd-bcm47xxpart-support-TRX-data-partition-being-UBI.patch
index 4c4720341e..46881fca2c 100644
--- a/target/linux/generic/patches-3.18/431-mtd-bcm47xxpart-support-TRX-data-partition-being-UBI.patch
+++ b/target/linux/generic/patches-3.18/431-mtd-bcm47xxpart-support-TRX-data-partition-being-UBI.patch
@@ -17,7 +17,7 @@
u64 offset, uint32_t mask_flags)
{
part->name = name;
-@@ -58,6 +59,26 @@ static void bcm47xxpart_add_part(struct
+@@ -58,6 +59,26 @@ static void bcm47xxpart_add_part(struct
part->mask_flags = mask_flags;
}
diff --git a/target/linux/generic/patches-3.18/502-yaffs-3.10-disable-proc-entry.patch b/target/linux/generic/patches-3.18/502-yaffs-3.10-disable-proc-entry.patch
index 5b73d3898b..5345678c56 100644
--- a/target/linux/generic/patches-3.18/502-yaffs-3.10-disable-proc-entry.patch
+++ b/target/linux/generic/patches-3.18/502-yaffs-3.10-disable-proc-entry.patch
@@ -8,7 +8,7 @@
static struct proc_dir_entry *my_proc_entry;
static char *yaffs_dump_dev_part0(char *buf, struct yaffs_dev *dev)
-@@ -3398,6 +3399,7 @@ static int yaffs_proc_write(struct file
+@@ -3398,6 +3399,7 @@ static int yaffs_proc_write(struct file
return yaffs_proc_debug_write(file, buf, count, data);
return yaffs_proc_write_trace_options(file, buf, count, data);
}