summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.18/832-ledtrig_usbdev.patch
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2014-10-27 18:14:39 +0000
committerRafał Miłecki <zajec5@gmail.com>2014-10-27 18:14:39 +0000
commit1513b39a8c8e21e3f8fbebab9fb4c41040ccf695 (patch)
tree7c786effff410b4a96d29c920d60cd279236fbf7 /target/linux/generic/patches-3.18/832-ledtrig_usbdev.patch
parent38e72c779e229933625d96d4355a0250123b6ce5 (diff)
downloadmaster-31e0f0ae-1513b39a8c8e21e3f8fbebab9fb4c41040ccf695.tar.gz
master-31e0f0ae-1513b39a8c8e21e3f8fbebab9fb4c41040ccf695.tar.bz2
master-31e0f0ae-1513b39a8c8e21e3f8fbebab9fb4c41040ccf695.zip
kernel: start working on 3.18 support
This commit: 1) Copies 3.14 patches 2) Drops mainlined stuff 3) Modifies some patches to apply Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 43093
Diffstat (limited to 'target/linux/generic/patches-3.18/832-ledtrig_usbdev.patch')
-rw-r--r--target/linux/generic/patches-3.18/832-ledtrig_usbdev.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.18/832-ledtrig_usbdev.patch b/target/linux/generic/patches-3.18/832-ledtrig_usbdev.patch
new file mode 100644
index 0000000000..d8c9492871
--- /dev/null
+++ b/target/linux/generic/patches-3.18/832-ledtrig_usbdev.patch
@@ -0,0 +1,31 @@
+--- a/drivers/leds/trigger/Kconfig
++++ b/drivers/leds/trigger/Kconfig
+@@ -119,4 +119,11 @@ config LEDS_TRIGGER_NETDEV
+ This allows LEDs to be controlled by network device activity.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_USBDEV
++ tristate "LED USB device Trigger"
++ depends on USB && LEDS_TRIGGERS
++ help
++ This allows LEDs to be controlled by the presence/activity of
++ an USB device. If unsure, say N.
++
+ endif # LEDS_TRIGGERS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -64,3 +64,4 @@ obj-$(CONFIG_LEDS_DAC124S085) += leds-d
+ obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
++obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
+--- a/drivers/leds/ledtrig-usbdev.c
++++ b/drivers/leds/ledtrig-usbdev.c
+@@ -24,7 +24,6 @@
+ #include <linux/list.h>
+ #include <linux/spinlock.h>
+ #include <linux/device.h>
+-#include <linux/sysdev.h>
+ #include <linux/timer.h>
+ #include <linux/ctype.h>
+ #include <linux/slab.h>