summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.18/430-mtd-add-myloader-partition-parser.patch
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2014-10-27 18:14:39 +0000
committerRafał Miłecki <zajec5@gmail.com>2014-10-27 18:14:39 +0000
commit1513b39a8c8e21e3f8fbebab9fb4c41040ccf695 (patch)
tree7c786effff410b4a96d29c920d60cd279236fbf7 /target/linux/generic/patches-3.18/430-mtd-add-myloader-partition-parser.patch
parent38e72c779e229933625d96d4355a0250123b6ce5 (diff)
downloadmaster-31e0f0ae-1513b39a8c8e21e3f8fbebab9fb4c41040ccf695.tar.gz
master-31e0f0ae-1513b39a8c8e21e3f8fbebab9fb4c41040ccf695.tar.bz2
master-31e0f0ae-1513b39a8c8e21e3f8fbebab9fb4c41040ccf695.zip
kernel: start working on 3.18 support
This commit: 1) Copies 3.14 patches 2) Drops mainlined stuff 3) Modifies some patches to apply Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 43093
Diffstat (limited to 'target/linux/generic/patches-3.18/430-mtd-add-myloader-partition-parser.patch')
-rw-r--r--target/linux/generic/patches-3.18/430-mtd-add-myloader-partition-parser.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.18/430-mtd-add-myloader-partition-parser.patch b/target/linux/generic/patches-3.18/430-mtd-add-myloader-partition-parser.patch
new file mode 100644
index 0000000000..ffc9e2199c
--- /dev/null
+++ b/target/linux/generic/patches-3.18/430-mtd-add-myloader-partition-parser.patch
@@ -0,0 +1,35 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -189,6 +189,22 @@ config MTD_BCM47XX_PARTS
+ This provides partitions parser for devices based on BCM47xx
+ boards.
+
++config MTD_MYLOADER_PARTS
++ tristate "MyLoader partition parsing"
++ depends on ADM5120 || ATHEROS_AR231X || ATHEROS_AR71XX || ATH79
++ ---help---
++ MyLoader is a bootloader which allows the user to define partitions
++ in flash devices, by putting a table in the second erase block
++ on the device, similar to a partition table. This table gives the
++ offsets and lengths of the user defined partitions.
++
++ If you need code which can detect and parse these tables, and
++ register MTD 'partitions' corresponding to each image detected,
++ enable this option.
++
++ You will still need the parsing functions to be called by the driver
++ for your particular device. It won't happen automatically.
++
+ comment "User Modules And Translation Layers"
+
+ #
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -19,6 +19,7 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+ obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
+ obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
+ obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
++obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
+
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_BLKDEVS) += mtd_blkdevs.o