summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.18/304-mips_disable_fpu.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2014-10-27 22:55:39 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2014-10-27 22:55:39 +0000
commita76ee3b1d5dee92a13ba357e9baf2ad155976604 (patch)
tree38745103e28135d9d7fc5fbfbc64a5eb7f6f49d3 /target/linux/generic/patches-3.18/304-mips_disable_fpu.patch
parentcea2b5299b13fcfef7de2f194e833e545e9e0f2f (diff)
downloadmaster-31e0f0ae-a76ee3b1d5dee92a13ba357e9baf2ad155976604.tar.gz
master-31e0f0ae-a76ee3b1d5dee92a13ba357e9baf2ad155976604.tar.bz2
master-31e0f0ae-a76ee3b1d5dee92a13ba357e9baf2ad155976604.zip
kernel: make the kernel 3.18 patches apply and boot on arm.
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 43095
Diffstat (limited to 'target/linux/generic/patches-3.18/304-mips_disable_fpu.patch')
-rw-r--r--target/linux/generic/patches-3.18/304-mips_disable_fpu.patch207
1 files changed, 76 insertions, 131 deletions
diff --git a/target/linux/generic/patches-3.18/304-mips_disable_fpu.patch b/target/linux/generic/patches-3.18/304-mips_disable_fpu.patch
index 4536ce6dae..980eaf0b7e 100644
--- a/target/linux/generic/patches-3.18/304-mips_disable_fpu.patch
+++ b/target/linux/generic/patches-3.18/304-mips_disable_fpu.patch
@@ -1,160 +1,105 @@
-MIPS: allow disabling the kernel FPU emulator
+From: Manuel Lauss <manuel.lauss@gmail.com>
+Subject: [RFC PATCH v4 2/2] MIPS: make FPU emulator optional
+Date: Mon, 7 Apr 2014 12:57:04 +0200
+Message-Id: <1396868224-252888-2-git-send-email-manuel.lauss@gmail.com>
-This patch allows turning off the in-kernel Algorithmics
-FPU emulator support, which allows one to save a couple of
-precious blocks on an embedded system.
+This small patch makes the MIPS FPU emulator optional. The kernel
+kills float-users on systems without a hardware FPU by sending a SIGILL.
+
+Disabling the emulator shrinks vmlinux by about 54kBytes (32bit,
+optimizing for size).
+
+Signed-off-by: Manuel Lauss <manuel.lauss@gmail.com>
+---
+v4: rediffed because of patch 1/2, should now work with micromips as well
+v3: updated patch description with size savings.
+v2: incorporated changes suggested by Jonas Gorski
+ force the fpu emulator on for micromips: relocating the parts
+ of the mmips code in the emulator to other areas would be a
+ much larger change; I went the cheap route instead with this.
+
+ arch/mips/Kbuild | 2 +-
+ arch/mips/Kconfig | 14 ++++++++++++++
+ arch/mips/include/asm/fpu.h | 5 +++--
+ arch/mips/include/asm/fpu_emulator.h | 15 +++++++++++++++
+ 4 files changed, 33 insertions(+), 3 deletions(-)
-Signed-off-by: Florian Fainelli <florian@openwrt.org>
---
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
-@@ -934,6 +934,17 @@ config I8259
- config MIPS_BONITO64
- bool
+@@ -2484,6 +2484,20 @@ config MIPS_O32_FP64_SUPPORT
+
+ If unsure, say N.
-+config MIPS_FPU_EMU
-+ bool "Enable FPU emulation"
++config MIPS_FPU_EMULATOR
++ bool "MIPS FPU Emulator"
+ default y
+ help
-+ This option allows building a kernel with or without the Algorithmics
-+ FPU emulator enabled. Turning off this option results in a kernel which
-+ does not catch floating operations exceptions. Make sure that your toolchain
-+ is configured to enable software floating point emulation in that case.
++ This option lets you disable the built-in MIPS FPU (Coprocessor 1)
++ emulator, which handles floating-point instructions on processors
++ without a hardware FPU. It is generally a good idea to keep the
++ emulator built-in, unless you are perfectly sure you have a
++ complete soft-float environment. With the emulator disabled, all
++ users of float operations will be killed with an illegal instr-
++ uction exception.
+
-+ If unsure say Y here.
++ Say Y, please.
+
- config MIPS_MSC
+ config USE_OF
bool
+ select OF
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -266,7 +266,7 @@ OBJCOPYFLAGS += --remove-section=.regin
+ head-y := arch/mips/kernel/head.o
---- a/arch/mips/math-emu/Makefile
-+++ b/arch/mips/math-emu/Makefile
-@@ -2,10 +2,12 @@
- # Makefile for the Linux/MIPS kernel FPU emulation.
- #
+ libs-y += arch/mips/lib/
+-libs-y += arch/mips/math-emu/
++libs-$(CONFIG_MIPS_FPU_EMULATOR) += arch/mips/math-emu/
--obj-y := cp1emu.o ieee754m.o ieee754d.o ieee754dp.o ieee754sp.o ieee754.o \
-+obj-y := kernel_linkage.o
-+
-+obj-$(CONFIG_MIPS_FPU_EMU) += ieee754m.o ieee754d.o ieee754dp.o ieee754sp.o ieee754.o \
- ieee754xcpt.o dp_frexp.o dp_modf.o dp_div.o dp_mul.o dp_sub.o \
- dp_add.o dp_fsp.o dp_cmp.o dp_logb.o dp_scalb.o dp_simple.o \
- dp_tint.o dp_fint.o dp_tlong.o dp_flong.o sp_frexp.o sp_modf.o \
- sp_div.o sp_mul.o sp_sub.o sp_add.o sp_fdp.o sp_cmp.o sp_logb.o \
- sp_scalb.o sp_simple.o sp_tint.o sp_fint.o sp_tlong.o sp_flong.o \
-- dp_sqrt.o sp_sqrt.o kernel_linkage.o dsemul.o
-+ dp_sqrt.o sp_sqrt.o dsemul.o cp1emu.o
---- a/arch/mips/math-emu/kernel_linkage.c
-+++ b/arch/mips/math-emu/kernel_linkage.c
-@@ -29,6 +29,7 @@
+ # See arch/mips/Kbuild for content of core part of the kernel
+ core-y += arch/mips/
+--- a/arch/mips/include/asm/fpu.h
++++ b/arch/mips/include/asm/fpu.h
+@@ -168,8 +168,10 @@ static inline int init_fpu(void)
+ ret = __own_fpu();
+ if (!ret)
+ _init_fpu();
+- } else
++ } else if (IS_ENABLED(CONFIG_MIPS_FPU_EMULATOR))
+ fpu_emulator_init_fpu();
++ else
++ ret = SIGILL;
- #define SIGNALLING_NAN 0x7ff800007ff80000LL
-
-+#ifdef CONFIG_MIPS_FPU_EMU
- void fpu_emulator_init_fpu(void)
- {
- static int first = 1;
-@@ -115,3 +116,36 @@ int fpu_emulator_restore_context32(struc
- return err;
+ return ret;
}
- #endif
-+
-+#else
-+
-+void fpu_emulator_init_fpu(void)
-+{
-+ printk(KERN_INFO "FPU emulator disabled, make sure your toolchain"
-+ "was compiled with software floating point support (soft-float)\n");
-+ return;
-+}
-+
-+int fpu_emulator_save_context(struct sigcontext __user *sc)
-+{
-+ return 0;
-+}
-+
-+int fpu_emulator_restore_context(struct sigcontext __user *sc)
-+{
-+ return 0;
-+}
-+
-+#ifdef CONFIG_64BIT
-+int fpu_emulator_save_context32(struct sigcontext32 __user *sc)
-+{
-+ return 0;
-+}
-+
-+int fpu_emulator_restore_context32(struct sigcontext32 __user *sc)
-+{
-+ return 0;
-+}
-+#endif /* CONFIG_64BIT */
-+
-+#endif /* CONFIG_MIPS_FPU_EMU */
--- a/arch/mips/include/asm/fpu_emulator.h
+++ b/arch/mips/include/asm/fpu_emulator.h
-@@ -27,6 +27,8 @@
- #include <asm/inst.h>
+@@ -30,6 +30,7 @@
#include <asm/local.h>
+ #include <asm/processor.h>
-+#ifdef CONFIG_MIPS_FPU_EMU
-+
++#ifdef CONFIG_MIPS_FPU_EMULATOR
#ifdef CONFIG_DEBUG_FS
struct mips_fpu_emulator_stats {
-@@ -60,6 +62,38 @@ extern int fpu_emulator_cop1Handler(stru
- int process_fpemu_return(int sig, void __user *fault_addr);
- int mm_isBranchInstr(struct pt_regs *regs, struct mm_decoded_insn dec_insn,
- unsigned long *contpc);
-+#else
-+static inline int mips_dsemul(struct pt_regs *regs, mips_instruction ir,
-+ unsigned long cpc)
-+{
-+ return 0;
-+}
-+
+@@ -65,6 +66,20 @@ extern int do_dsemulret(struct pt_regs *
+ extern int fpu_emulator_cop1Handler(struct pt_regs *xcp,
+ struct mips_fpu_struct *ctx, int has_fpu,
+ void *__user *fault_addr);
++#else /* no CONFIG_MIPS_FPU_EMULATOR */
+static inline int do_dsemulret(struct pt_regs *xcp)
+{
-+ return 0;
++ return 0; /* 0 means error, should never get here anyway */
+}
+
+static inline int fpu_emulator_cop1Handler(struct pt_regs *xcp,
-+ struct mips_fpu_struct *ctx,
-+ int has_fpu,
-+ void *__user *fault_addr)
-+{
-+ return 0;
-+}
-+
-+static inline int process_fpemu_return(int sig, void __user *fault_addr)
++ struct mips_fpu_struct *ctx, int has_fpu,
++ void *__user *fault_addr)
+{
-+ return -EINVAL;
++ return SIGILL; /* we don't speak MIPS FPU */
+}
++#endif /* CONFIG_MIPS_FPU_EMULATOR */
+
-+static inline int mm_isBranchInstr(struct pt_regs *regs,
-+ struct mm_decoded_insn dec_insn,
-+ unsigned long *contpc)
-+{
-+ return 0;
-+}
-+#endif /* CONFIG_MIPS_FPU_EMU */
-
- /*
- * Instruction inserted following the badinst to further tag the sequence
---- a/arch/mips/kernel/traps.c
-+++ b/arch/mips/kernel/traps.c
-@@ -701,6 +701,7 @@ asmlinkage void do_ov(struct pt_regs *re
- exception_exit(prev_state);
- }
-
-+#ifdef CONFIG_MIPS_FPU_EMU
- int process_fpemu_return(int sig, void __user *fault_addr)
- {
- if (sig == SIGSEGV || sig == SIGBUS) {
-@@ -724,6 +725,7 @@ int process_fpemu_return(int sig, void _
- return 0;
- }
- }
-+#endif /* CONFIG_MIPS_FPU_EMU */
-
- /*
- * XXX Delayed fp exceptions when doing a lazy ctx switch XXX
+ int process_fpemu_return(int sig, void __user *fault_addr);
+ int mm_isBranchInstr(struct pt_regs *regs, struct mm_decoded_insn dec_insn,
+ unsigned long *contpc);