summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.14/728-phy-rtl8367b.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-12-22 14:37:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-12-22 14:37:07 +0000
commit550642098095652b7454199cc98986c01057da8e (patch)
tree11e57334c617b88e69400d0d338852b95b69a578 /target/linux/generic/patches-3.14/728-phy-rtl8367b.patch
parent7d6a7492787c16a1efbc10fc86b79b53f85da588 (diff)
downloadmaster-31e0f0ae-550642098095652b7454199cc98986c01057da8e.tar.gz
master-31e0f0ae-550642098095652b7454199cc98986c01057da8e.tar.bz2
master-31e0f0ae-550642098095652b7454199cc98986c01057da8e.zip
kernel: remove openwrt micrel.c (replaced by upstream driver)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43762
Diffstat (limited to 'target/linux/generic/patches-3.14/728-phy-rtl8367b.patch')
-rw-r--r--target/linux/generic/patches-3.14/728-phy-rtl8367b.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.14/728-phy-rtl8367b.patch b/target/linux/generic/patches-3.14/728-phy-rtl8367b.patch
new file mode 100644
index 0000000000..36a82311fe
--- /dev/null
+++ b/target/linux/generic/patches-3.14/728-phy-rtl8367b.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -257,6 +257,10 @@ config RTL8367_PHY
+ tristate "Driver for the Realtek RTL8367R/M switches"
+ select SWCONFIG
+
++config RTL8367B_PHY
++ tristate "Driver fot the Realtek RTL8367R-VB switch"
++ select SWCONFIG
++
+ endif # RTL8366_SMI
+
+ endif # PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -27,6 +27,7 @@ obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi
+ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
+ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
++obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o